]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blob - apache1-mod_mp3.spec
- up to 0.39 STBR
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
1 %define         arname          mod_mp3
2 %define         mod_name        mp3
3 %define         apxs            /usr/sbin/apxs
4 Summary:        MP3 Apache module
5 Summary(pl):    Modu³ MP3 do Apache
6 Name:           apache-mod_mp3
7 Version:        0.39
8 Release:        1
9 License:        BSD
10 Group:          Networking/Daemons
11 Source0:        http://software.tangent.org/download/%{arname}-%{version}.tar.gz
12 Source1:        %{arname}.conf
13 URL:            http://media.tangent.org/
14 Requires:       apache >= 1.3.12
15 Prereq:         grep
16 Prereq:         apache(EAPI) >= 1.3.12
17 Prereq:         %{_sbindir}/apxs
18 Provides:       %{arname}
19 BuildRequires:  %{apxs}
20 BuildRequires:  apache(EAPI)-devel >= 1.3.12
21 BuildRequires:  expat-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
25 %define         _sysconfdir     /etc/httpd
26
27 %prep
28 %setup -q -n %{arname}-%{version}
29
30 %description
31 This turns apache into your basic RIAA hating, but every college
32 student loving mp3 streaming server. It can play from a list of files,
33 either straight through or randomly. It can also be used to cache
34 mp3's into memory and have the server operate entirely from memory.
35 Enjoy, groove, mp3s not included.
36
37 %description -l pl
38 Ten pakiet zamienia Twojego Apache w znienawidzony przez RIAA, ale
39 uwielbiany przez studentów serwer strumieni MP3. Mo¿e odtwarzaæ listê
40 plików, w kolejno¶ci lub losowo. Mo¿e byæ tak¿e u¿yty do buforowania
41 plików mp3 w pamiêci, pozwalaj±c serwerowi operowaæ wy³±cznie na
42 pamiêci. Baw siê dobrze; pliki mp3 nie s± za³±czone.
43
44 %build
45 ./configure
46 %{__make} APXS=%{apxs}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
51
52 install src/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
60 if [ -f %{_sysconfdir}/httpd.conf ] && \
61         ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
62                 echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
63 fi
64 if [ -f /var/lock/subsys/httpd ]; then
65         /etc/rc.d/init.d/httpd restart 1>&2
66 fi
67
68 %preun
69 if [ "$1" = "0" ]; then
70         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
71         grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
72         %{_sysconfdir}/httpd.conf.tmp
73         mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
74         if [ -f /var/lock/subsys/httpd ]; then
75                 /etc/rc.d/init.d/httpd restart 1>&2
76         fi
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README ChangeLog LICENSE faq.html support
82 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mod_mp3.conf
83 %attr(755,root,root) %{_pkglibdir}/mod_mp3.so
This page took 0.086462 seconds and 3 git commands to generate.