]> git.pld-linux.org Git - packages/apache1-mod_limitipconn.git/commitdiff
- new
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 15 Feb 2010 14:56:38 +0000 (14:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache.conf -> 1.1
    apache1-mod_limitipconn.spec -> 1.1

apache.conf [new file with mode: 0644]
apache1-mod_limitipconn.spec [new file with mode: 0644]

diff --git a/apache.conf b/apache.conf
new file mode 100644 (file)
index 0000000..90ab9a6
--- /dev/null
@@ -0,0 +1,21 @@
+LoadModule limitipconn_module  modules/mod_limitipconn.so
+
+# This module will not function unless mod_status is loaded and the "ExtendedStatus On" directive is set.
+#ExtendedStatus On
+
+<IfModule mod_limitipconn.c>
+#      <Location /somewhere>
+#              MaxConnPerIP 3
+#              # exempting images from the connection limit is often a good
+#              # idea if your web page has lots of inline images, since these
+#              # pages often generate a flurry of concurrent image requests
+#              NoIPLimit image/*
+#      </Location>
+#
+#      <Location /mp3>
+#              MaxConnPerIP 1
+#              # In this case, all MIME types other than audio/mpeg and video*
+#              # are exempt from the limit check
+#              OnlyIPLimit audio/mpeg video
+#      </Location>
+</IfModule>
diff --git a/apache1-mod_limitipconn.spec b/apache1-mod_limitipconn.spec
new file mode 100644 (file)
index 0000000..631474b
--- /dev/null
@@ -0,0 +1,56 @@
+%define                mod_name        limitipconn
+%define        apxs            %{_sbindir}/apxs1
+Summary:       Apache module: Limit simultaneous connections by an IP address
+Name:          apache1-mod_%{mod_name}
+Version:       0.04
+Release:       0.1
+License:       X11
+Group:         Networking/Daemons
+Source0:       http://dominia.org/djao/limit/mod_limitipconn-%{version}.tar.gz
+# Source0-md5: 009dac6ccae20806916ec7aa61a42a1f
+Source1:       apache.conf
+URL:           http://dominia.org/djao/limitipconn.html
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: rpmbuild(macros) >= 1.228
+Requires:      apache1(EAPI)
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+
+%description
+The mod_limitipconn module lets you enforce limits on the number of
+simultaneous downloads allowed from a single IP address. You can also
+control which MIME types are affected by the limits.
+
+This module will not function unless mod_status is loaded and the
+"ExtendedStatus On" directive is set.
+
+%prep
+%setup -q -n mod_%{mod_name}-%{version}
+
+%build
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
+install -p mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%service apache restart
+
+%postun
+if [ "$1" = "0" ]; then
+       %service -q apache restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.139709 seconds and 4 git commands to generate.