]> git.pld-linux.org Git - packages/apache1-mod_hosts_access.git/blob - apache1-mod_hosts_access.spec
- no macros in URLs, pl fix
[packages/apache1-mod_hosts_access.git] / apache1-mod_hosts_access.spec
1 %define         mod_name        hosts_access
2 %define         apxs            %{_sbindir}/apxs1
3 Summary:        Apache module: access defined by hosts.allow/hosts.deny
4 Summary(pl):    Modu³ do apache: dostêp na podstawie hosts.allow/hosts.deny
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.0.0
7 Release:        0.1
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://www.klomp.org/mod_hosts_access/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  3720e303cfde50e94586f484a903aa41
12 URL:            http://www.klomp.org/mod_hosts_access/
13 BuildRequires:  apache1-devel
14 BuildRequires:  libwrap-devel
15 Requires(post,preun):   %{apxs}
16 Requires:       apache1
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20 %define         _sysconfdir     /etc/httpd
21
22 %description
23 Mod_hosts_access allows you to use the hosts.allow and hosts.deny
24 files to configure access to your apache webserver.
25
26 %description -l pl
27 Mod_hosts_access pozwala u¿ywaæ plików hosts.allow i hosts.deny do
28 okre¶lania dostêpu do zasobów serwera WWW apache.
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 %{apxs} -c mod_%{mod_name}.c -lwrap
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_pkglibdir}
39
40 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47 if [ -f /var/lock/subsys/httpd ]; then
48         /etc/rc.d/init.d/httpd restart 1>&2
49 fi
50
51 %preun
52 if [ "$1" = "0" ]; then
53         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
54         if [ -f /var/lock/subsys/httpd ]; then
55                 /etc/rc.d/init.d/httpd restart 1>&2
56         fi
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README INSTALL
62 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.063982 seconds and 4 git commands to generate.