]> git.pld-linux.org Git - packages/apache1-mod_gzip.git/commitdiff
- Based on apache-mod_gunzip.spec.
authormkochano <mkochano@pld-linux.org>
Wed, 7 Nov 2001 15:15:35 +0000 (15:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- Builds and works, but Source: lines may cause conflicts in CVS as file
  names do not contain package name ("changes.txt" for example).

Changed files:
    apache1-mod_gzip.spec -> 1.1

apache1-mod_gzip.spec [new file with mode: 0644]

diff --git a/apache1-mod_gzip.spec b/apache1-mod_gzip.spec
new file mode 100644 (file)
index 0000000..67f368a
--- /dev/null
@@ -0,0 +1,70 @@
+%define                mod_name        gzip
+Summary:       Apache module: On-the-fly compression of HTML documents
+Summary(pl):   Modu³ do apache: kompresuje dokumenty HTML w locie
+Name:          apache-mod_%{mod_name}
+Version:       1.3.19.1a
+Release:       1
+License:       Apache Software License
+Group:         Networking/Daemons
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
+Source0:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/mod_%{mod_name}.c
+Source1:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/changes.txt
+Source2:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/commands.txt
+Source3:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/samples.txt
+BuildRequires: /usr/sbin/apxs
+BuildRequires: apache(EAPI)-devel
+BuildRequires: zlib-devel
+Prereq:                /usr/sbin/apxs
+Requires:      apache(EAPI)
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+
+%description
+Apache module: On-the-fly compression of HTML documents. Browser will
+transparently decompress and display such documents.
+
+%description -l pl
+Modu³ do apache: kompresuje dokumenty HTML w locie. Przegl±daki w sposób
+przezroczysty dekompresuj± i wy¶wietlaj± takie dokumenty.
+
+%prep 
+%setup -q -T -c
+cp %{SOURCE0} .
+cp %{SOURCE1} .
+cp %{SOURCE2} .
+cp %{SOURCE3} .
+
+%build
+/usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_pkglibdir}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+gzip -9nf *.txt
+
+%post
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc *.gz
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.058144 seconds and 4 git commands to generate.