]> git.pld-linux.org Git - packages/apache1-mod_gzip.git/blob - apache1-mod_gzip.spec
- tabs in preamble
[packages/apache1-mod_gzip.git] / apache1-mod_gzip.spec
1 %define         mod_name        gzip
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: On-the-fly compression of HTML documents
4 Summary(pl.UTF-8):      Moduł do apache: kompresuje dokumenty HTML w locie
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.3.26.1a
7 Release:        3
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/mod-gzip/mod_gzip-%{version}.tgz
11 # Source0-md5:  080ccc5d789ed5efa0c0a7625e4fa02d
12 Source1:        %{name}.conf
13 Source2:        %{name}.logrotate
14 Patch0:         %{name}-name_clash.patch
15 Patch1:         %{name}-security.patch
16 URL:            http://www.schroepl.net/projekte/mod_gzip/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache1-devel >= 1.3.33-2
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  zlib-devel
21 Requires(triggerpostun):        %{apxs}
22 Requires(triggerpostun):        grep
23 Requires(triggerpostun):        sed >= 4.0
24 Requires:       apache1(EAPI)
25 Obsoletes:      apache-mod_gzip <= 1.3.26.1a
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
30 %define         _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
31
32 %description
33 Apache module: On-the-fly compression of HTML documents. Browser will
34 transparently decompress and display such documents.
35
36 %description -l pl.UTF-8
37 Moduł do apache: kompresuje dokumenty HTML w locie. Przeglądarki w
38 sposób przezroczysty dekompresują i wyświetlają takie dokumenty.
39
40 %prep
41 %setup -q -n mod_%{mod_name}-%{version}
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 %{apxs} -Wc,-Wall,-pipe -c mod_%{mod_name}.c mod_%{mod_name}_debug.c mod_%{mod_name}_compress.c -o mod_%{mod_name}.so
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,/etc/logrotate.d,%{_pkglogdir}}
51
52 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
54 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
55
56 > $RPM_BUILD_ROOT%{_pkglogdir}/mod_gzip.log
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %service -q apache restart
63
64 %postun
65 if [ "$1" = "0" ]; then
66         %service -q apache restart
67 fi
68
69 %triggerpostun -- %{name} < 1.3.26.1a-1.1
70 if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
71         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
72         sed -i -e '
73                 /^Include.*mod_%{mod_name}\.conf/d
74         ' /etc/apache/apache.conf
75 else
76         # they're still using old apache.conf
77         sed -i -e '
78                 s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
79         ' /etc/apache/apache.conf
80 fi
81 %service -q apache restart
82
83 %files
84 %defattr(644,root,root,755)
85 %doc docs/manual/english/*
86 %lang(de) %doc docs/manual/deutsch
87 %attr(755,root,root) %{_pkglibdir}/*
88 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
89 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
90 %attr(640,root,root) %ghost %{_pkglogdir}/*
This page took 0.072501 seconds and 3 git commands to generate.