]> git.pld-linux.org Git - packages/apache1-mod_gunzip.git/blob - apache1-mod_gunzip.spec
- Requires: apache(EAPI).
[packages/apache1-mod_gunzip.git] / apache1-mod_gunzip.spec
1 %define         mod_name        gunzip
2 Summary:        Apache module: On-the-fly decompression of HTML documents
3 Summary(pl):    Modu³ do apache: dekompresuje dokumenty HTML w locie
4 Name:           apache-mod_%{mod_name}
5 Version:        1
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://sep.hamburg.com/mod_%{mod_name}.tar.gz
11 BuildRequires:  /usr/sbin/apxs
12 BuildRequires:  apache(EAPI)-devel
13 BuildRequires:  zlib-devel
14 Prereq:         /usr/sbin/apxs
15 Requires:       apache(EAPI)
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
19
20 %description
21 Apache module: On-the-fly decompression of HTML documents.
22
23 %description -l pl
24 Modu³ do apache: dekompresuje dokumenty HTML w locie.
25
26 %prep 
27 %setup -q -n mod_%{mod_name}
28
29 %build
30 %{_sbindir}/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 install -d $RPM_BUILD_ROOT%{_pkglibdir}
36
37 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
38
39 strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/* 
40
41 %post
42 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
43 if [ -f /var/lock/subsys/httpd ]; then
44         %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
45 fi
46
47 %preun
48 if [ "$1" = "0" ]; then
49         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50         if [ -f /var/lock/subsys/httpd ]; then
51                 /etc/rc.d/init.d/httpd restart 1>&2
52         fi
53 fi
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.0785 seconds and 3 git commands to generate.