]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blame - apache1-mod_frontpage.spec
- initial release, not ready yet !
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
CommitLineData
73331299 1%define mod_name frontpage
2%define arname mod_%{mod_name}
3%define apxs /usr/sbin/apxs
4
5Summary: The improved mod_frontpage module for the Apache Web server.
6Name: apache-mod_%{mod_name}
7Version: 1.6.1
8Release: 0.1
9Group: Networking/Daemons
10URL: http://home.edo.uni-dortmund.de/~chripo/
11#Source0: http://home.edo.uni-dortmund.de/~chripo/download/%{name}-%{version}mdk-1.3.19.tar.bz2
12#The patch is now maintained by FreeBSD
13Source0: http://people.freebsd.org/~mbr/distfiles/mod_frontpage-%{version}.tar.bz2
14Patch0: mod_frontpage-PLD.patch
15Patch1: mod_frontpage-Makefile.patch
16License: Apache License
17Prereq: grep
18Prereq: apache(EAPI) >= 1.3.23
19Prereq: %{_sbindir}/apxs
20Requires: apache
21BuildRequires: apache(EAPI)-devel >= 1.3.23
22BuildRequires: perl
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
26%define _sysconfdir /etc/httpd
27
28%description
29This is a module for the Apache HTTP Server
30<http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
31and module supplied with the FrontPage Server Extensions available
32from Microsoft <http://www.microsoft.com> and Ready-to-Run Software
33<http://www.rtr.com/fpsupport>.
34
35Using this module allows you to use advanced features of the FrontPage
36client with your Apache HTTP Server (e.g. creating FrontPage-extended
37subwebs using the FrontPage client in contrast to creating them as
38user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
39system's shell).
40
41%prep
42%setup -q -n %{arname}-%{version}
43%patch -p0
44%patch1 -p0
45
46%build
47perl Makefile.PL
48%{__make} CFLAGS="%{rpmcflags} -DLINUX=22 -DINET6 -Dss_family=__ss_family -Dss_len=__ss_len -DDEV_RANDOM=/dev/random -DEAPI -DEAPI_MM"
49
50%install
51rm -rf $RPM_BUILD_ROOT
52install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
53install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
54install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
55
56gzip -9nf {CHANGES,FEATURES,INSTALL,LICENSE,README}
57
58%post
59%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
60if [ -f /var/lock/subsys/httpd ]; then
61 /etc/rc.d/init.d/httpd restart 1>&2
62fi
63
64%preun
65 if [ "$1" = "0" ]; then
66 %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
67 if [ -f /var/lock/subsys/httpd ]; then
68 /etc/rc.d/init.d/httpd restart 1>&2
69 fi
70fi
71
72%files
73%defattr(644,root,root,755)
74%attr(755,root,root) %{_pkglibdir}/*
75%attr(4550,root,root) %{_sbindir}/fpexec
76%attr(0555,root,root) %{_sbindir}/fpstatic
77%doc *.gz
78
79%clean
80rm -rf $RPM_BUILD_ROOT
This page took 0.077713 seconds and 4 git commands to generate.