]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blobdiff - apache1-mod_fastcgi.spec
- converted to UTF-8
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
index 630ab0767d369c398c5d489d78ef045fb050b9c2..1f97f7ca56a1212f60483d9c15d9741fa947e5e8 100644 (file)
@@ -1,20 +1,30 @@
+%define                mod_name        fastcgi
+%define        apxs            /usr/sbin/apxs1
 Summary:       Support for the FastCGI protocol for apache webserver
 Summary:       Support for the FastCGI protocol for apache webserver
-Summary(pl):   Obs³uga protoko³u FastCGI dla serwera apache
-Name:          apache-mod_fastcgi
-Version:       2.2.10
-Release:       2
-Copyright:     Open Market
+Summary(pl.UTF-8):   Obsługa protokołu FastCGI dla serwera apache
+Summary(ru.UTF-8):   FastCGI - более быстрая версия CGI
+Summary(uk.UTF-8):   FastCGI - більш швидка версія CGI
+Name:          apache1-mod_%{mod_name}
+# NOTE: remember about apache-mod_fastcgi.spec when messing here
+Version:       2.4.2
+Release:       4
+License:       distributable
 Group:         Networking/Daemons
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Source0:       http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
+Source0:       http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
+# Source0-md5: e994414304b535cb99e10b7d1cad1d1e
+Patch0:                %{name}-allow-uid-gid.patch
+Patch1:                %{name}-socketdir.patch
 URL:           http://www.FastCGI.com/
 URL:           http://www.FastCGI.com/
-BuildRequires: apache-devel
-Requires:      apache >= 1.3.1
+BuildRequires: %{apxs}
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: libtool
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache1(EAPI)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _libexecdir     %{_libdir}/apache
-%define         _htmldocdir     /home/httpd/manual/mod
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                _socketdir      /var/run/apache/fastcgi
 
 %description
 This 3rd party module provides support for the FastCGI protocol.
 
 %description
 This 3rd party module provides support for the FastCGI protocol.
@@ -22,48 +32,57 @@ FastCGI is a language independent, scalable, open extension to CGI
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
-%description -l pl
-To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
-niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
-du¿± wydajno¶æ bez ograniczania API specificznego dla serwera.
+%description -l pl.UTF-8
+To jest moduł apache dodający obsługę protokołu FastCGI. FastCGI jest
+niezależnym od języka, skalowalnym, otwartym rozszerzeniem CGI dającym
+dużą wydajność bez ograniczania API specyficznego dla serwera.
+
+%description -l ru.UTF-8
+FastCGI - расширение CGI, которое предоставляет возможность создавать
+высокопроизводительные Internet-приложения без необходимости
+использовать специфические для каждого web-сервера API.
+
+Скорость API web-серверов со всеми преимуществами CGI.
+
+%description -l uk.UTF-8
+FastCGI - розширення CGI, яке надає можливість створювати
+високопродуктивні Internet-програми без необхідності використання
+специфічних для кожного web-серверу API.
+
+Швидкість API web-серверів зі всіма перевагами CGI.
 
 %prep
 
 %prep
-%setup -q -n mod_fastcgi_%{version}
+%setup -q -n mod_%{mod_name}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
 
 %build
-apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
+%{apxs} -S CC="%{__cc}" -o mod_%{mod_name}.so -c *.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_socketdir}/dynamic}
 
 
-install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
 
-install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
 
 
-gzip -9nf docs/LICENSE.TERMS CHANGES
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 
 %post
-%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
-fi
+%service -q apache restart
 
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q apache restart
 fi
 
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %files
 %defattr(644,root,root,755)
-%doc docs/*.gz *.gz
-%doc %{_htmldocdir}
-%attr(755,root,root) %{_libexecdir}/*
+%doc docs/LICENSE.TERMS CHANGES docs/*.html
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
+%dir %attr(770,root,http) %{_socketdir}
+%dir %attr(770,root,http) %{_socketdir}/dynamic
This page took 0.186168 seconds and 4 git commands to generate.