]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- release 2
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 Summary:        Support for the FastCGI protocol for apache webserver
2 Name:           apache-mod_fastcgi
3 Version:        2.2.10
4 Release:        2
5 Copyright:      Open Market
6 Group:          Networking/Daemons
7 Group(de):      Netzwerkwesen/Server
8 Group(pl):      Sieciowe/Serwery
9 Source0:        http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
10 URL:            http://www.FastCGI.com/
11 BuildRequires:  apache-devel
12 Requires:       apache >= 1.3.1
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _libexecdir     %{_libdir}/apache
16 %define         _htmldocdir     /home/httpd/manual/mod
17
18 %description
19 This 3rd party module provides support for the FastCGI protocol.
20 FastCGI is a language independent, scalable, open extension to CGI
21 that provides high performance and persistence without the limitations
22 of server specific APIs.
23
24 %prep
25 %setup -q -n mod_fastcgi_%{version}
26
27 %build
28 apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
29 strip mod_fastcgi.so
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
34
35 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
36
37 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
38
39 gzip -9nf docs/LICENSE.TERMS CHANGES
40
41 %post
42 %{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
43 if [ -f /var/lock/subsys/httpd ]; then
44         /etc/rc.d/init.d/httpd restart 1>&2
45 else
46         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
47 fi
48
49 %preun
50 if [ "$1" = "0" ]; then
51         %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
52         if [ -f /var/lock/subsys/httpd ]; then
53                 /etc/rc.d/init.d/httpd restart 1>&2
54         fi
55 fi
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc docs/*.gz *.gz
63 %doc %{_htmldocdir}
64 %attr(755,root,root) %{_libexecdir}/*
This page took 0.070665 seconds and 4 git commands to generate.