]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- apache 1.3 support
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 %define         apxs    /usr/sbin/apxs
2 %define         _apache1        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 0 || echo 1)
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache-mod_fastcgi
8 Version:        2.4.2
9 Release:        1
10 License:        distributable
11 Group:          Networking/Daemons
12 Source0:        http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
13 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
14 Source1:        70_mod_fastcgi.conf
15 URL:            http://www.FastCGI.com/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel
18 BuildRequires:  libtool
19 Requires(post,preun):   %{apxs}
20 Requires:       apache >= 1.3.1
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _libexecdir     %{_libdir}/apache
24 %define         _htmldocdir     /home/httpd/manual/mod
25
26 %description
27 This 3rd party module provides support for the FastCGI protocol.
28 FastCGI is a language independent, scalable, open extension to CGI
29 that provides high performance and persistence without the limitations
30 of server specific APIs.
31
32 %description -l pl
33 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
34 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
35 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
36
37 %description -l ru
38 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
39 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
40 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
41
42 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
43
44 %description -l uk
45 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
46 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
47 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
48
49 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
50
51 %prep
52 %setup -q -n mod_fastcgi-%{version}
53
54 %build
55 %if %{_apache1}
56 %{apxs} -o mod_fastcgi.so -c *.c
57 %else
58 %{__make} -f Makefile.AP2 top_dir=%{_libexecdir} INCLUDES="-I%{_includedir}/apache"
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
64
65 %if %{_apache1}
66 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
67 %else
68 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf
69 libtool --mode=install install mod_fastcgi.la $RPM_BUILD_ROOT%{_libexecdir}
70 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/httpd.conf/
71 %endif
72
73 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 %if %{_apache1}
80 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
81 %endif
82 if [ -f /var/lock/subsys/httpd ]; then
83         /etc/rc.d/init.d/httpd restart 1>&2
84 else
85         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
86 fi
87  
88 %preun
89 if [ "$1" = "0" ]; then
90 %if %{_apache1}
91         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
92 %endif
93         if [ -f /var/lock/subsys/httpd ]; then
94                 /etc/rc.d/init.d/httpd restart 1>&2
95         fi
96 fi
97  
98 %files
99 %defattr(644,root,root,755)
100 %doc docs/LICENSE.TERMS CHANGES
101 %doc %{_htmldocdir}/*
102 %attr(755,root,root) %{_libexecdir}/*
103 %if ! %{_apache1}
104 %config %{_sysconfdir}/httpd/httpd.conf/*.conf
105 %endif
This page took 0.039691 seconds and 4 git commands to generate.