]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- added %{apxs} local macro to avoid adapter problems
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 %define         apxs    /usr/sbin/apxs
2 Summary:        Support for the FastCGI protocol for apache webserver
3 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
4 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
5 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
6 Name:           apache-mod_fastcgi
7 Version:        2.2.10
8 Release:        4
9 License:        Open Market
10 Group:          Networking/Daemons
11 Group(cs):      Sí»ové/Démoni
12 Group(da):      Netværks/Dæmoner
13 Group(de):      Netzwerkwesen/Server
14 Group(es):      Red/Servidores
15 Group(fr):      Réseau/Serveurs
16 Group(is):      Net/Púkar
17 Group(it):      Rete/Demoni
18 Group(no):      Nettverks/Daemoner
19 Group(pl):      Sieciowe/Serwery
20 Group(pt):      Rede/Servidores
21 Group(ru):      óÅÔØ/äÅÍÏÎÙ
22 Group(sl):      Omre¾ni/Stre¾niki
23 Group(sv):      Nätverk/Demoner
24 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
25 Source0:        http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
26 URL:            http://www.FastCGI.com/
27 BuildRequires:  apache-devel
28 BuildRequires:  %{apxs}
29 Prereq:         %{_sbindir}/apxs
30 Requires:       apache >= 1.3.1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _libexecdir     %{_libdir}/apache
34 %define         _htmldocdir     /home/httpd/manual/mod
35
36 %description
37 This 3rd party module provides support for the FastCGI protocol.
38 FastCGI is a language independent, scalable, open extension to CGI
39 that provides high performance and persistence without the limitations
40 of server specific APIs.
41
42 %description -l pl
43 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
44 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
45 du¿± wydajno¶æ bez ograniczania API specificznego dla serwera.
46
47 %description -l ru
48 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
49 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
50 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
51
52 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
53
54 %description -l uk
55 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
56 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
57 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
58
59 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
60
61 %prep
62 %setup -q -n mod_fastcgi_%{version}
63
64 %build
65 %{apxs} -D SUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_fastcgi.so -c *.c
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
70
71 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
72
73 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
74
75 gzip -9nf docs/LICENSE.TERMS CHANGES
76
77 %post
78 %{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
79 if [ -f /var/lock/subsys/httpd ]; then
80         /etc/rc.d/init.d/httpd restart 1>&2
81 else
82         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
83 fi
84
85 %preun
86 if [ "$1" = "0" ]; then
87         %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
88         if [ -f /var/lock/subsys/httpd ]; then
89                 /etc/rc.d/init.d/httpd restart 1>&2
90         fi
91 fi
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc docs/*.gz *.gz
99 %doc %{_htmldocdir}
100 %attr(755,root,root) %{_libexecdir}/*
This page took 0.04433 seconds and 4 git commands to generate.