]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- release 2
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 Summary:        Support for the FastCGI protocol for apache webserver
2 Name:           apache-mod_fastcgi
3 Version:        2.2.8
4 Release:        2
5 Copyright:      Open Market
6 Group:          Networking/Daemons
7 Group(de):      Netzwerkwesen/Server
8 Group(pl):      Sieciowe/Serwery
9 URL:            http://www.FastCGI.com/
10 Source0:        http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
11 Requires:       apache >= 1.3.1
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13 BuildRequires:  apache-devel
14
15 %description
16 This 3rd party module provides support for the FastCGI protocol.
17 FastCGI is a language independent, scalable, open extension to CGI
18 that provides high performance and persistence without the limitations
19 of server specific APIs.
20
21 %define         _libexecdir     /usr/lib/apache
22 %define         _htmldocdir     /home/httpd/html/docs/%{name}_%{version}
23
24 %prep
25 %setup -q -n mod_fastcgi_%{version}
26
27 %build
28 apxs -D SUEXEC_BIN="/usr/sbin/suexec" -o mod_fastcgi.so -c *.c
29 strip mod_fastcgi.so
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
34
35 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
36
37 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
38
39 gzip -9nf docs/LICENSE.TERMS CHANGES
40
41 strip --strip-unneeded $RPM_BUILD_ROOT%{_libexecdir}/*
42
43 %post
44 %{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
45 if [ -f /var/lock/subsys/httpd ]; then
46         /etc/rc.d/init.d/httpd restart 1>&2
47 else
48         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
49 fi
50
51 %preun
52 if [ "$1" = "0" ]; then
53         %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
54         if [ -f /var/lock/subsys/httpd ]; then
55                 /etc/rc.d/init.d/httpd restart 1>&2
56         fi
57 fi
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc docs/*.gz CHANGES.gz
65 %doc %{_htmldocdir}
66 %attr(755,root,root) %{_libexecdir}/*
This page took 0.074214 seconds and 4 git commands to generate.