]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- unified (not everything, waiting for server-side cp)
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 %define         mod_name        fastcgi
2 %define         apxs            /usr/sbin/apxs
3 %define         _apache1        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 0 || echo 1)
4 Summary:        Support for the FastCGI protocol for apache webserver
5 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
6 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
7 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
8 Name:           apache-mod_%{mod_name}
9 Version:        2.4.2
10 Release:        2
11 License:        distributable
12 Group:          Networking/Daemons
13 Source0:        http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
15 Patch0:         %{name}-allow-uid-gid.patch
16 Source1:        70_mod_%{mod_name}.conf
17 URL:            http://www.FastCGI.com/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel
20 BuildRequires:  libtool
21 Requires(post,preun):   %{apxs}
22 Requires:       apache >= 1.3.1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
27 %define         _htmldocdir     /home/httpd/manual/mod
28
29 %description
30 This 3rd party module provides support for the FastCGI protocol.
31 FastCGI is a language independent, scalable, open extension to CGI
32 that provides high performance and persistence without the limitations
33 of server specific APIs.
34
35 %description -l pl
36 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
37 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
38 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
39
40 %description -l ru
41 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
42 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
43 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
44
45 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
46
47 %description -l uk
48 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
49 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
50 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
51
52 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
53
54 %prep
55 %setup -q -n mod_%{mod_name}-%{version}
56 %patch0 -p1
57
58 %build
59 %if %{_apache1}
60 %{apxs} -o mod_%{mod_name}.so -c *.c
61 %else
62 %{__make} -f Makefile.AP2 top_dir=%{_pkglibdir} INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_htmldocdir}}
68
69 %if %{_apache1}
70 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
71 %else
72 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
73 libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
74 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/
75 %endif
76
77 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 %if %{_apache1}
84 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
85 %endif
86 if [ -f /var/lock/subsys/httpd ]; then
87         /etc/rc.d/init.d/httpd restart 1>&2
88 else
89         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
90 fi
91  
92 %preun
93 if [ "$1" = "0" ]; then
94 %if %{_apache1}
95         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
96 %endif
97         if [ -f /var/lock/subsys/httpd ]; then
98                 /etc/rc.d/init.d/httpd restart 1>&2
99         fi
100 fi
101  
102 %files
103 %defattr(644,root,root,755)
104 %doc docs/LICENSE.TERMS CHANGES
105 %doc %{_htmldocdir}/*
106 %attr(755,root,root) %{_pkglibdir}/*.so
107 %if ! %{_apache1}
108 %config %{_sysconfdir}/httpd.conf/*.conf
109 %endif
This page took 0.094845 seconds and 3 git commands to generate.