]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- release 3.
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 Summary:        Support for the FastCGI protocol for apache webserver
2 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
3 Name:           apache-mod_fastcgi
4 Version:        2.2.10
5 Release:        3
6 License:        Open Market
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
11 URL:            http://www.FastCGI.com/
12 BuildRequires:  apache-devel
13 Requires:       apache >= 1.3.1
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _libexecdir     %{_libdir}/apache
17 %define         _htmldocdir     /home/httpd/manual/mod
18
19 %description
20 This 3rd party module provides support for the FastCGI protocol.
21 FastCGI is a language independent, scalable, open extension to CGI
22 that provides high performance and persistence without the limitations
23 of server specific APIs.
24
25 %description -l pl
26 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
27 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
28 du¿± wydajno¶æ bez ograniczania API specificznego dla serwera.
29
30 %prep
31 %setup -q -n mod_fastcgi_%{version}
32
33 %build
34 apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
39
40 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
41
42 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
43
44 gzip -9nf docs/LICENSE.TERMS CHANGES
45
46 %post
47 %{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
48 if [ -f /var/lock/subsys/httpd ]; then
49         /etc/rc.d/init.d/httpd restart 1>&2
50 else
51         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc docs/*.gz *.gz
68 %doc %{_htmldocdir}
69 %attr(755,root,root) %{_libexecdir}/*
This page took 0.159604 seconds and 3 git commands to generate.