]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- some small changes, inpired by kloczek
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 %define         apxs    /usr/sbin/apxs
2 Summary:        Support for the FastCGI protocol for apache webserver
3 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
4 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
5 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
6 Name:           apache-mod_fastcgi
7 Version:        2.4.0
8 Release:        1
9 License:        distributable
10 Group:          Networking/Daemons
11 Source0:        http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
12 # Source0-md5:  e4f5b1b185db4774021163dd0fcd2c56
13 URL:            http://www.FastCGI.com/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel
16 Requires(post,preun):   %{apxs}
17 Requires:       apache >= 1.3.1
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _libexecdir     %{_libdir}/apache
21 %define         _htmldocdir     /home/httpd/manual/mod
22
23 %description
24 This 3rd party module provides support for the FastCGI protocol.
25 FastCGI is a language independent, scalable, open extension to CGI
26 that provides high performance and persistence without the limitations
27 of server specific APIs.
28
29 %description -l pl
30 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
31 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
32 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
33
34 %description -l ru
35 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
36 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
37 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
38
39 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
40
41 %description -l uk
42 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
43 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
44 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
45
46 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
47
48 %prep
49 %setup -q -n mod_fastcgi-%{version}
50
51 %build
52 %{apxs} -D SUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_fastcgi.so -c *.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
57
58 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
59 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %{apxs} -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
66 if [ -f /var/lock/subsys/httpd ]; then
67         /etc/rc.d/init.d/httpd restart 1>&2
68 else
69         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
70 fi
71
72 %preun
73 if [ "$1" = "0" ]; then
74         %{apxs} -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
75         if [ -f /var/lock/subsys/httpd ]; then
76                 /etc/rc.d/init.d/httpd restart 1>&2
77         fi
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc docs/LICENSE.TERMS CHANGES
83 %doc %{_htmldocdir}/*
84 %attr(755,root,root) %{_libexecdir}/*
This page took 0.069206 seconds and 3 git commands to generate.