]> git.pld-linux.org Git - packages/apache1-mod_dav.git/blob - apache1-mod_dav.spec
- updated to 1.0.3,
[packages/apache1-mod_dav.git] / apache1-mod_dav.spec
1 Summary:        WebDAV module for the Apache Web server
2 Summary(pl):    Modu³ WebDAV dla webserwera Apache
3 %define         apache_version  1.3.6
4 %define         mod_name        dav
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0.3
7 Release:        1
8 License:        OSI Approved
9 Group:          Networking/Daemons
10 Group(de):      Netzwerkwesen/Server
11 Group(pl):      Sieciowe/Serwery
12 Source0:        http://www.webdav.org/mod_dav/mod_%{mod_name}-%{version}-%{apache_version}.tar.gz
13 URL:            http://www.webdav.org/mod_dav/
14 Prereq:         /usr/sbin/apxs
15 BuildRequires:  /usr/sbin/apxs
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  apache(EAPI)-devel      >= %{apache_version}
19 Requires:       apache(EAPI)            >= %{apache_version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 Obsoletes:      mod_dav
22
23 %define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
24
25 %description
26 mod_dav enables Apache to understand DAV protocol (extensions to
27 HTTP). DAV stands for "Distributed Authoring and Versioning", and is
28 defined by RFC 2518. DAV is intended to replace proprietary authoring
29 protocols such as those used by Frontpage or NetObjects' Fusion, but
30 is also a complete set of protocols for manipulating a webserver's
31 files and directories, and their properties.
32
33 %description -l pl
34 mod_dav w³±cza w Apache obs³ugê protoko³u DAV (rozszerzenie HTTP). DAV
35 oznacza "Dystrybuowane Oznaczanie i Wersjonowanie", i jest
36 zdefiniowany w RFC 2518. Podstawow± misj± DAV jest zast±piæ takie
37 protoko³y jak te u¿ywane w Frontpage czy NetObjects' Fusion. Lecz DAV
38 to tak¿e kompletny zestaw protoko³ów s³u¿±cych do manipulowania
39 plikami i katalogami serwera Web, oraz ich w³±¶ciwo¶ciami.
40
41 %prep 
42 %setup -q -n mod_%{mod_name}-%{version}-%{apache_version}
43
44 %build
45 aclocal
46 autoconf
47 %configure \
48         --with-apxs=/usr/sbin/apxs
49 %{__make} APXS=/usr/sbin/apxs
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_pkglibdir}
54
55 install lib%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/
56
57 gzip -9nf README CHANGES INSTALL
58
59 %post
60 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
61 if [ -f /var/lock/subsys/httpd ]; then
62         %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
63 fi
64
65 %preun
66 if [ "$1" = "0" ]; then
67         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
68         if [ -f /var/lock/subsys/httpd ]; then
69                 /etc/rc.d/init.d/httpd restart 1>&2
70         fi
71 fi
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc *.gz LICENSE.html
79 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.480448 seconds and 3 git commands to generate.