]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/blob - apache1-mod_cvs.spec
- this is apache1 module; release 1, waiting for server-side cp
[packages/apache1-mod_cvs.git] / apache1-mod_cvs.spec
1 %define         mod_name        cvs
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: Automatically updates files in a CVS-based webtree
4 Summary(pl):    Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
5 Name:           apache1-mod_%{mod_name}
6 Version:        0.5
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 # working URL: http://www.sub.nu/mod_cvs/src/
11 # (but only separate files here, no tarball)
12 Source0:        ftp://ftp.sub.nu/pub/mod_cvs/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e2cfe7818337915e6cbaffa45852012f
14 URL:            http://www.sub.nu/mod_cvs/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache1-devel
17 BuildRequires:  zlib-devel
18 Requires(post,preun):   %{apxs}
19 Requires:       apache1
20 Obsoletes:      apache-mod_%{mod_name} <= %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24
25 %description
26 Apache module: Automatically updates files in a CVS-based webtree.
27
28 %description -l pl
29 Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS.
30
31 %prep
32 %setup -q -n mod_%{mod_name}-%{version}
33
34 %build
35 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_pkglibdir}
40
41 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
48 if [ -f /var/lock/subsys/apache ]; then
49         /etc/rc.d/init.d/apache restart 1>&2
50 fi
51
52 %preun
53 if [ "$1" = "0" ]; then
54         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
55         if [ -f /var/lock/subsys/apache ]; then
56                 /etc/rc.d/init.d/apache restart 1>&2
57         fi
58 fi
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README
63 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.271032 seconds and 3 git commands to generate.