]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/blob - apache1-mod_cvs.spec
6574e016e42ee8872811e5088148cff01bba343b
[packages/apache1-mod_cvs.git] / apache1-mod_cvs.spec
1 %define         mod_name        cvs
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Automatically updates files in a CVS-based webtree
4 Summary(pl):    Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
5 Name:           apache-mod_%{mod_name}
6 Version:        0.5
7 Release:        4
8 License:        GPL
9 Group:          Networking/Daemons
10 # working URL: http://www.sub.nu/mod_cvs/src/
11 # (but only separate files here, no tarball)
12 Source0:        ftp://ftp.sub.nu/pub/mod_cvs/mod_%{mod_name}-%{version}.tar.gz
13 URL:            http://www.sub.nu/mod_cvs/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel
16 BuildRequires:  zlib-devel
17 Requires(post,preun):   %{apxs}
18 Requires:       apache
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
22
23 %description
24 Apache module: Automatically updates files in a CVS-based webtree.
25
26 %description -l pl
27 Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS.
28
29 %prep
30 %setup -q -n mod_%{mod_name}-%{version}
31
32 %build
33 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_pkglibdir}
38
39 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
46 if [ -f /var/lock/subsys/httpd ]; then
47         /etc/rc.d/init.d/httpd restart 1>&2
48 fi
49
50 %preun
51 if [ "$1" = "0" ]; then
52         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
53         if [ -f /var/lock/subsys/httpd ]; then
54                 /etc/rc.d/init.d/httpd restart 1>&2
55         fi
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README
61 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.039883 seconds and 2 git commands to generate.