]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/blob - apache1-mod_cvs.spec
- massive attack: source-md5
[packages/apache1-mod_cvs.git] / apache1-mod_cvs.spec
1 %define         mod_name        cvs
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Automatically updates files in a CVS-based webtree
4 Summary(pl):    Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
5 Name:           apache-mod_%{mod_name}
6 Version:        0.5
7 Release:        4
8 License:        GPL
9 Group:          Networking/Daemons
10 # working URL: http://www.sub.nu/mod_cvs/src/
11 # (but only separate files here, no tarball)
12 Source0:        ftp://ftp.sub.nu/pub/mod_cvs/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e2cfe7818337915e6cbaffa45852012f
14 URL:            http://www.sub.nu/mod_cvs/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel
17 BuildRequires:  zlib-devel
18 Requires(post,preun):   %{apxs}
19 Requires:       apache
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
23
24 %description
25 Apache module: Automatically updates files in a CVS-based webtree.
26
27 %description -l pl
28 Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS.
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_pkglibdir}
39
40 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47 if [ -f /var/lock/subsys/httpd ]; then
48         /etc/rc.d/init.d/httpd restart 1>&2
49 fi
50
51 %preun
52 if [ "$1" = "0" ]; then
53         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
54         if [ -f /var/lock/subsys/httpd ]; then
55                 /etc/rc.d/init.d/httpd restart 1>&2
56         fi
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.077762 seconds and 3 git commands to generate.