]> git.pld-linux.org Git - packages/apache1-mod_become.git/blob - apache1-mod_become.spec
d1390ef4720ed838f97605be4c070e90a6ed8a70
[packages/apache1-mod_become.git] / apache1-mod_become.spec
1 %define         mod_name        become
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: Become Somebody
4 Summary(pl.UTF-8):      Moduł Apache'a: stawanie się kimś
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.3
7 Release:        3
8 License:        ?
9 Group:          Networking/Daemons
10 Source0:        http://www.snert.com/Software/mod_become/mod_become103.tgz
11 # Source0-md5:  7bb1607587687dabc711b3b1903947e5
12 URL:            http://www.snert.com/Software/mod_become/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache1-devel >= 1.3.33-2
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires(triggerpostun):        %{apxs}
17 Requires:       apache1(EAPI)
18 Obsoletes:      apache-mod_become <= 1.3
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
22 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
23
24 %description
25 This module enables the web server to take on the access rights of a
26 user & group, so that users can make available files to the web
27 without having to make them readable by the world on the local file
28 system. This can be useful for sites with a large number of users who
29 want to apply file access controls among themselves. This module can
30 also be applied to virtual hosts, directories, and locations.
31
32 %description -l pl.UTF-8
33 Ten moduł pozwala serwerowi WWW przejąć prawa dostępu użytkownika i
34 grupy, dzięki czemu użytkownicy mogą udostępnić pliki na WWW bez
35 czynienia ich globalnie czytelnymi w lokalnym systemie plików. Może to
36 być przydatne na dla serwerów z dużą liczbą użytkowników, którzy chcą
37 kontrolować dostęp do plików między sobą. Ten moduł może być używany
38 także z serwerami wirtualnymi, katalogami i miejscami.
39
40 %prep
41 %setup -q -n mod_%{mod_name}-%{version}
42
43 %build
44 PATH=$PATH:%{_sbindir}
45 %{__make} build-dynamic \
46         APXS=%{apxs}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
51
52 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53
54 echo '#LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
55         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 echo "mod_%{mod_name}: This module is not turned on by default; if you're sure,"
62 echo "mod_%{mod_name}: uncomment the appropriate line in Apache's config file."
63
64 %postun
65 if [ "$1" = "0" ]; then
66         %service -q apache restart
67 fi
68
69 %triggerpostun -- apache1-mod_%{mod_name} < 1.3-1.1
70 # check that they're not using old apache.conf
71 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
72         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc CHANGES.txt LICENSE.txt SECURITY.txt index.shtml notes-conf.txt
78 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
79 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.037915 seconds and 2 git commands to generate.