]> git.pld-linux.org Git - packages/apache1-mod_become.git/blob - apache1-mod_become.spec
1721dc97b9e1c59329b3258487f4dcd6259120fa
[packages/apache1-mod_become.git] / apache1-mod_become.spec
1 %define         mod_name        become
2 %define         apxs            %{_sbindir}/apxs
3 Summary:        Apache module: Become Somebody
4 Summary(pl):    Modu³ Apache'a: stawanie siê kim¶
5 Name:           apache-mod_%{mod_name}
6 Version:        1.3
7 Release:        1
8 License:        ?
9 Group:          Networking/Daemons
10 Source0:        http://www.snert.com/Software/mod_become/mod_become103.tgz
11 # Source0-md5:  7bb1607587687dabc711b3b1903947e5
12 URL:            http://www.snert.com/Software/mod_become/
13 BuildRequires:  apache(EAPI)-devel
14 Requires(post,preun):   %{apxs}
15 Requires(post,preun):   grep
16 Requires(preun):        fileutils
17 Requires:       apache(EAPI)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21 %define         _sysconfdir     /etc/httpd
22
23 %description
24 This module enables the web server to take on the access rights of a
25 user & group, so that users can make available files to the web
26 without having to make them readable by the world on the local file
27 system. This can be useful for sites with a large number of users who
28 want to apply file access controls among themselves. This module can
29 also be applied to virtual hosts, directories, and locations.
30
31 %description -l pl
32 Ten modu³ pozwala serwerowi WWW przej±æ prawa dostêpu u¿ytkownika i
33 grupy, dziêki czemu u¿ytkownicy mog± udostêpniæ pliki na WWW bez
34 czynienia ich globalnie czytelnymi w lokalnym systemie plików. Mo¿e to
35 byæ przydatne na dla serwerów z du¿± liczb± u¿ytkowników, którzy chc±
36 kontrolowaæ dostêp do plików miêdzy sob±. Ten modu³ mo¿e byæ u¿ywany
37 tak¿e z serwerami wirtualnymi, katalogami i miejscami.
38
39 %prep
40 %setup -q -n mod_%{mod_name}-%{version}
41
42 %build
43 PATH=$PATH:%{_sbindir}
44 %{__make} build-dynamic
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
49
50 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
61         if [ -f /var/lock/subsys/httpd ]; then
62                 /etc/rc.d/init.d/httpd restart 1>&2
63         fi
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CHANGES.txt LICENSE.txt SECURITY.txt index.shtml notes-conf.txt
69 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.04988 seconds and 3 git commands to generate.