]> git.pld-linux.org Git - packages/apache1-mod_auth_samba.git/blob - apache1-mod_auth_samba.spec
- new & works for me.
[packages/apache1-mod_auth_samba.git] / apache1-mod_auth_samba.spec
1 %define         mod_name        auth_samba
2 Summary:        This is the samba authentication module for Apache
3 Name:           apache-mod_%{mod_name}
4 Version:        1.1
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(pl):      Sieciowe/Serwery
9 Source0:        ftp://download.sourceforge.net/pub/sourceforge/modauthsamba/mod_%{mod_name}-%{version}.tar.gz
10 BuildRequires:  /usr/sbin/apxs
11 BuildRequires:  apache(EAPI)-devel
12 Prereq:         /usr/sbin/apxs
13 Requires:       apache(EAPI)
14 URL:            http://modauthsamba.sourceforge.net/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
18
19 %description
20 This is an authentication module for Apache that allows you to
21 authenticate HTTP clients using user entries in an samba directory.
22
23 %prep 
24 %setup -q -n mod_%{mod_name}
25
26 %build
27 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31
32 install -d $RPM_BUILD_ROOT%{_pkglibdir}
33
34 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
35
36 strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/* 
37
38 %post
39 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
40 if [ -f /var/lock/subsys/httpd ]; then
41         %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
42 fi
43
44 %preun
45 if [ "$1" = "0" ]; then
46         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47         if [ -f /var/lock/subsys/httpd ]; then
48                 /etc/rc.d/init.d/httpd restart 1>&2
49         fi
50 fi
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.068692 seconds and 3 git commands to generate.