]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blob - apache1-mod_auth_pgsql.spec
bb6df7c2fb1ab8f2e66ab3328cd18836001d1ccf
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ autentykacji PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        0.9.12
17 Release:        3
18 License:        GPL
19 Group:          Networking/Daemons
20 Group(cs):      Sí»ové/Démoni
21 Group(da):      Netværks/Dæmoner
22 Group(de):      Netzwerkwesen/Server
23 Group(es):      Red/Servidores
24 Group(fr):      Réseau/Serveurs
25 Group(is):      Net/Púkar
26 Group(it):      Rete/Demoni
27 Group(no):      Nettverks/Daemoner
28 Group(pl):      Sieciowe/Serwery
29 Group(pt):      Rede/Servidores
30 Group(ru):      óÅÔØ/äÅÍÏÎÙ
31 Group(sl):      Omre¾ni/Stre¾niki
32 Group(sv):      Nätverk/Demoner
33 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
34 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
35 BuildRequires:  postgresql-devel
36 BuildRequires:  %{apxs}
37 BuildRequires:  apache(EAPI)-devel
38 Prereq:         %{_sbindir}/apxs
39 Requires:       apache(EAPI)
40 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
44
45 %description
46 This is an authentication module for Apache that allows you to
47 authenticate HTTP clients using postgresql RDBMS.
48
49 %description -l cs
50 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
51 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
52 PostgreSQL.
53
54 %description -l de
55 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
56 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
57 einer Tabelle in einer PostgresQL-Datenbank prüft.
58
59 %description -l es
60 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
61 servidos desde un servidor web verificando datos en una base de datos
62 PostgreSQL.
63
64 %description -l fr
65 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
66 servis par un serveur Web en vérifiant des champs dans une table d'une
67 base de données PostgresQL.
68
69 %description -l it
70 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
71 serviti da un server Web controllando i campi di una tabella in un
72 database PostgresQL.
73
74 %description -l ja
75 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
76 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
77 À©¸Â¤Ç¤­¤Þ¤¹¡£
78
79 %description -l pl
80 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
81 klientów HTTP z u¿yciem bazy danych postgresql.
82
83 %description -l pt_BR
84 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
85 PostgreSQL.
86
87 %description -l sv
88 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
89 servade av en webbserver genom att kontrollera data i en
90 PostgreSQL-databas.
91
92 %prep
93 %setup -q -n "mod_%{mod_name}-%{version}"
94
95 %build
96 %{apxs} \
97         -I %{_includedir}/postgresql \
98         -l pq \
99         -c mod_%{mod_name}.c \
100         -o mod_%{mod_name}.so
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_pkglibdir}
105
106 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %{_sbindir}/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
113 if [ -f /var/lock/subsys/httpd ]; then
114         /etc/rc.d/init.d/httpd restart 1>&2
115 fi
116
117 %preun
118 if [ "$1" = "0" ]; then
119         %{_sbindir}/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
120         if [ -f /var/lock/subsys/httpd ]; then
121                 /etc/rc.d/init.d/httpd restart 1>&2
122         fi
123 fi
124
125 %files
126 %defattr(644,root,root,755)
127 %doc *.html
128 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.045349 seconds and 2 git commands to generate.