]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blob - apache1-mod_auth_pgsql.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ autentykacji PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        0.9.12
17 Release:        3
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
21 BuildRequires:  postgresql-devel
22 BuildRequires:  %{apxs}
23 BuildRequires:  apache(EAPI)-devel
24 Prereq:         %{_sbindir}/apxs
25 Requires:       apache(EAPI)
26 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
30
31 %description
32 This is an authentication module for Apache that allows you to
33 authenticate HTTP clients using postgresql RDBMS.
34
35 %description -l cs
36 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
37 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
38 PostgreSQL.
39
40 %description -l de
41 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
42 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
43 einer Tabelle in einer PostgresQL-Datenbank prüft.
44
45 %description -l es
46 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
47 servidos desde un servidor web verificando datos en una base de datos
48 PostgreSQL.
49
50 %description -l fr
51 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
52 servis par un serveur Web en vérifiant des champs dans une table d'une
53 base de données PostgresQL.
54
55 %description -l it
56 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
57 serviti da un server Web controllando i campi di una tabella in un
58 database PostgresQL.
59
60 %description -l ja
61 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
62 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
63 À©¸Â¤Ç¤­¤Þ¤¹¡£
64
65 %description -l pl
66 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
67 klientów HTTP z u¿yciem bazy danych postgresql.
68
69 %description -l pt_BR
70 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
71 PostgreSQL.
72
73 %description -l sv
74 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
75 servade av en webbserver genom att kontrollera data i en
76 PostgreSQL-databas.
77
78 %prep
79 %setup -q -n "mod_%{mod_name}-%{version}"
80
81 %build
82 %{apxs} \
83         -I %{_includedir}/postgresql \
84         -l pq \
85         -c mod_%{mod_name}.c \
86         -o mod_%{mod_name}.so
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_pkglibdir}
91
92 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 %{_sbindir}/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
99 if [ -f /var/lock/subsys/httpd ]; then
100         /etc/rc.d/init.d/httpd restart 1>&2
101 fi
102
103 %preun
104 if [ "$1" = "0" ]; then
105         %{_sbindir}/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
106         if [ -f /var/lock/subsys/httpd ]; then
107                 /etc/rc.d/init.d/httpd restart 1>&2
108         fi
109 fi
110
111 %files
112 %defattr(644,root,root,755)
113 %doc *.html
114 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.069897 seconds and 3 git commands to generate.