]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blob - apache1-mod_auth_pgsql.spec
- release 4: mod_auth_pgsql added to Obsoletes.
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ autentykacji PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        0.9.12
17 Release:        4
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
21 BuildRequires:  postgresql-devel
22 BuildRequires:  %{apxs}
23 BuildRequires:  apache(EAPI)-devel
24 Prereq:         %{_sbindir}/apxs
25 Requires:       apache(EAPI)
26 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28 Obsoletes:      mod_auth_pgsql
29
30 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
31
32 %description
33 This is an authentication module for Apache that allows you to
34 authenticate HTTP clients using postgresql RDBMS.
35
36 %description -l cs
37 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
38 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
39 PostgreSQL.
40
41 %description -l de
42 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
43 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
44 einer Tabelle in einer PostgresQL-Datenbank prüft.
45
46 %description -l es
47 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
48 servidos desde un servidor web verificando datos en una base de datos
49 PostgreSQL.
50
51 %description -l fr
52 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
53 servis par un serveur Web en vérifiant des champs dans une table d'une
54 base de données PostgresQL.
55
56 %description -l it
57 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
58 serviti da un server Web controllando i campi di una tabella in un
59 database PostgresQL.
60
61 %description -l ja
62 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
63 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
64 À©¸Â¤Ç¤­¤Þ¤¹¡£
65
66 %description -l pl
67 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
68 klientów HTTP z u¿yciem bazy danych postgresql.
69
70 %description -l pt_BR
71 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
72 PostgreSQL.
73
74 %description -l sv
75 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
76 servade av en webbserver genom att kontrollera data i en
77 PostgreSQL-databas.
78
79 %prep
80 %setup -q -n "mod_%{mod_name}-%{version}"
81
82 %build
83 %{apxs} \
84         -I %{_includedir}/postgresql \
85         -l pq \
86         -c mod_%{mod_name}.c \
87         -o mod_%{mod_name}.so
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_pkglibdir}
92
93 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 %{_sbindir}/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
100 if [ -f /var/lock/subsys/httpd ]; then
101         /etc/rc.d/init.d/httpd restart 1>&2
102 fi
103
104 %preun
105 if [ "$1" = "0" ]; then
106         %{_sbindir}/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
107         if [ -f /var/lock/subsys/httpd ]; then
108                 /etc/rc.d/init.d/httpd restart 1>&2
109         fi
110 fi
111
112 %files
113 %defattr(644,root,root,755)
114 %doc *.html
115 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.837652 seconds and 3 git commands to generate.