]> git.pld-linux.org Git - packages/apache1-mod_auth_pam.git/blob - apache1-mod_auth_pam.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_auth_pam.git] / apache1-mod_auth_pam.spec
1 %define         mod_name        auth_pam
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        This is the PAM authentication module for Apache
4 Summary(es.UTF-8):      Este módulo proporciona autenticación PAM para Apache
5 Summary(pl.UTF-8):      Moduł uwierzytelnienia PAM dla Apache
6 Summary(pt_BR.UTF-8):   Este módulo provê autenticação PAM para o Apache
7 Name:           apache1-mod_%{mod_name}
8 Version:        1.1.1
9 Release:        5
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://pam.sourceforge.net/mod_auth_pam/dist/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  b1e36b5df18a177e671785f7f4c8001c
14 Patch0:         %{name}-symbol_fix.patch
15 Patch1:         %{name}-broken_lines.patch
16 URL:            http://pam.sourceforge.net/mod_auth_pam/
17 BuildRequires:  apache1-devel >= 1.3.39
18 BuildRequires:  pam-devel
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires(triggerpostun):        %{apxs}
21 Requires:       apache1(EAPI)
22 Obsoletes:      apache-mod_auth_pam <= 1.1.1-4
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 This is an authentication module for Apache that allows you to
30 authenticate HTTP clients using PAM (pluggable authentication module).
31
32 %description -l es.UTF-8
33 Este módulo permite autenticar clientes HTTP usando el directorio PAM.
34
35 %description -l pl.UTF-8
36 To jest moduł uwierzytelnienia dla Apache pozwalający na
37 uwierzytelnianie klientów HTTP przez PAM.
38
39 %description -l pt_BR.UTF-8
40 Este módulo permite que você autentique clientes HTTP usando o
41 diretório PAM.
42
43 %prep
44 %setup -q -n mod_%{mod_name}-%{version}
45 %patch0 -p1
46 %patch1 -p0
47
48 %build
49 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lpam -ldl
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,/etc/pam.d}
54
55 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56 install samples/httpd- $RPM_BUILD_ROOT/etc/pam.d/httpd
57
58 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
59         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %service -q apache restart
66
67 %postun
68 if [ "$1" = "0" ]; then
69         %service -q apache restart
70 fi
71
72 %triggerpostun -- apache1-mod_%{mod_name} < 1.1.1-3.1
73 # check that they're not using old apache.conf
74 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
75         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc doc/{configure,faq}.txt samples/dot-htaccess README
81 %config(noreplace) /etc/pam.d/httpd
82 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
83 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.028461 seconds and 3 git commands to generate.