]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/commitdiff
- confdir enabled apache1 (no triggers as it wasn't on ftp)
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 10 Feb 2005 18:03:35 +0000 (18:03 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix for missing auth_mysql_config.h

Changed files:
    apache1-mod_auth_mysql.spec -> 1.34

apache1-mod_auth_mysql.spec

index ab2846b33a914d0d64a51dbe6206ae52860a5e19..8f2f14cf0e41cf498a73aefb2d779f56bcef7562 100644 (file)
@@ -1,3 +1,5 @@
+# TODO
+# - doesn't build
 %define                mod_name        auth_mysql
 %define                apxs            /usr/sbin/apxs1
 Summary:       This is the MySQL authentication module for Apache
 %define                mod_name        auth_mysql
 %define                apxs            /usr/sbin/apxs1
 Summary:       This is the MySQL authentication module for Apache
@@ -14,24 +16,24 @@ Summary(pt_BR):     Autentica
 Summary(sv):   Grundläggande autenticering för webbservern Apache med en MySQL-databas
 Name:          apache1-mod_%{mod_name}
 Version:       2.20
 Summary(sv):   Grundläggande autenticering för webbservern Apache med en MySQL-databas
 Name:          apache1-mod_%{mod_name}
 Version:       2.20
-Release:       1
+Release:       1.1
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://www.diegonet.com/support/mod_auth_mysql-%{version}.tar.gz
 # Source0-md5: 3e88c23aabf2089fc753b2631a938f53
 URL:           http://www.diegonet.com/support/mod_auth_mysql.shtml
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://www.diegonet.com/support/mod_auth_mysql-%{version}.tar.gz
 # Source0-md5: 3e88c23aabf2089fc753b2631a938f53
 URL:           http://www.diegonet.com/support/mod_auth_mysql.shtml
-BuildRequires: apache1-devel
+BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: mysql-devel
 BuildRequires: %{apxs}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: mysql-devel
 BuildRequires: %{apxs}
-Requires(post,preun):  %{_sbindir}/apxs
-Requires:      apache1
+Requires:      apache1 >= 1.3.33-2
 Requires:      apache1-mod_auth
 Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 Requires:      apache1-mod_auth
 Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 This is an authentication module for Apache that allows you to
 
 %description
 This is an authentication module for Apache that allows you to
@@ -89,26 +91,28 @@ MySQL-databas.
        --with-apxs=%{apxs} \
        --with-mysql=%{_prefix}
 
        --with-apxs=%{apxs} \
        --with-mysql=%{_prefix}
 
+ln -sf config.h auth_mysql_config.h
 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
@@ -117,4 +121,5 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README* USAGE
 %files
 %defattr(644,root,root,755)
 %doc README* USAGE
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.045479 seconds and 4 git commands to generate.