]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blob - apache1-mod_auth_mysql.spec
- add -lmysqlclient to build command
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 Summary:        This is the PAM authentication module for Apache
3 Name:           apache-mod_%{mod_name}
4 Version:        0.3
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.kcilink.com/pub/mod_%{mod_name}.c.gz
11 BuildRequires:  mysql-devel
12 BuildRequires:  /usr/sbin/apxs
13 BuildRequires:  apache(EAPI)-devel
14 Prereq:         /usr/sbin/apxs
15 Requires:       apache(EAPI)
16 URL:            http://modntlm.sourceforge.net/
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
20
21 %description
22 This is an authentication module for Apache that allows you to
23 authenticate HTTP clients using mysql RDBMS.
24
25 %prep 
26 %setup -T -c
27 cp %{SOURCE0} .
28 gzip -d mod_%{mod_name}.c.gz
29
30 %build
31 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{_pkglibdir}
36
37 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
38
39 %post
40 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
41 if [ -f /var/lock/subsys/httpd ]; then
42         /etc/rc.d/init.d/httpd restart 1>&2
43 fi
44
45 %preun
46 if [ "$1" = "0" ]; then
47         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
48         if [ -f /var/lock/subsys/httpd ]; then
49                 /etc/rc.d/init.d/httpd restart 1>&2
50         fi
51 fi
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.038175 seconds and 3 git commands to generate.