]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blob - apache1-mod_auth_mysql.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ autentykacji MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        0.11
17 Release:        4
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        ftp://ftp.kcilink.com/pub/mod_%{mod_name}.c.gz
21 Source1:        ftp://ftp.kciLink.com/pub/mysql-group-auth.txt
22 Patch0:         %{name}-name.patch
23 BuildRequires:  mysql-devel
24 BuildRequires:  %{apxs}
25 BuildRequires:  apache(EAPI)-devel
26 Prereq:         %{_sbindir}/apxs
27 Requires:       apache(EAPI)
28 Requires:       apache-mod_auth
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
32
33 %description
34 This is an authentication module for Apache that allows you to
35 authenticate HTTP clients using mysql RDBMS.
36
37 %description -l cs
38 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
39 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
40 MySQL.
41
42 %description -l de
43 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
44 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
45 einer MySQL-Datenbank prüft.
46
47 %description -l es
48 mod_auth_mysql puede usarse para limitar el acceso a documentos
49 servidos por un servidor web verificando datos en una base de datos
50 MySQL.
51
52 %description -l fr
53 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
54 servis par un serveur Web en vérifiant les données dans une base de
55 données MySQL.
56
57 %description -l it
58 mod_auth_mysql può essere usato per limitare l'accesso a documenti
59 serviti da un server Web controllando i dati in un database MySQL.
60
61 %description -l ja
62 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
63 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
64 ¤¬¤Ç¤­¤Þ¤¹¡£
65
66 %description -l pl
67 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
68 klientów HTTP z u¿yciem bazy danych mysql.
69
70 %description -l pt_BR
71 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
72 MySQL.
73
74 %description -l sv
75 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
76 servade av en webbserver genom att kontrollera data i en
77 MySQL-databas.
78
79 %prep
80 %setup -q -T -c
81 gzip -dc %{SOURCE0} > mod_%{mod_name}.c
82 %patch -p1
83
84 %build
85 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_pkglibdir}
90
91 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
92
93 install %{SOURCE1} .
94
95 gzip -9nf *.txt
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
102 if [ -f /var/lock/subsys/httpd ]; then
103         /etc/rc.d/init.d/httpd restart 1>&2
104 fi
105
106 %preun
107 if [ "$1" = "0" ]; then
108         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
109         if [ -f /var/lock/subsys/httpd ]; then
110                 /etc/rc.d/init.d/httpd restart 1>&2
111         fi
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %doc *.gz
117 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.109918 seconds and 3 git commands to generate.