]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blob - apache1-mod_auth_checkpasswd.spec
d3c8b95381b5ba6a5cc8801a32c638b44c7a452f
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
1 %define         mod_name        auth_checkpasswd
2 Summary:        This is the CHECKPASSWD authentication module for Apache
3 Summary(pl):    To jest modu³ Apache autentykuj±cy przez CHECKPASSWD
4 Name:           apache-mod_%{mod_name}
5 Version:        1.0
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        mod_%{mod_name}-%{version}.tar.gz
12 BuildRequires:  /usr/sbin/apxs
13 BuildRequires:  apache(EAPI)-devel
14 Prereq:         /usr/sbin/apxs
15 Requires:       apache(EAPI)
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
19
20 %description
21 This is an authentication module for Apache that uses an external
22 application compatibile with DJB's "checkpasswd".
23 The application may be setuid, which gives you a possibility to verify
24 passwords using regular /etc/shadow.
25
26 %description -l pl
27 To jest modu³ autentykuj±cy dla Apache który wykorzystuje zewnêtrzn±
28 aplikacjê kompatybiln± z "checkpasswd" DJB.
29 Aplikacja mo¿e byæ suidowana, co daje mo¿liwo¶æ weryfikowania hase³
30 wykorzystuj±c zwyk³y plik /etc/shadow.
31
32 %prep 
33 %setup -q -c -n "mod_%{mod_name}-%{version}"
34
35 %build
36 /usr/sbin/apxs \
37         -c mod_%{mod_name}.c \
38         -o mod_%{mod_name}.so
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_pkglibdir}
43
44 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45
46 gzip -9nf README
47
48 %post
49 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50 if [ -f /var/lock/subsys/httpd ]; then
51         /etc/rc.d/init.d/httpd restart 1>&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc *.gz
68 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.070468 seconds and 2 git commands to generate.