]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blob - apache1-mod_auth_checkpasswd.spec
- use %service
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
1 %define         mod_name        auth_checkpasswd
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        This is the CHECKPASSWD authentication module for Apache
4 Summary(pl):    To jest modu³ Apache uwierzytelniaj±cy przez CHECKPASSWD
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.0
7 Release:        2
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  7f699981ada026656affe2e35409bdf2
12 Patch0:         %{name}-aplog.patch
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache1-devel >= 1.3.33-2
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires(triggerpostun):        %{apxs}
17 Requires:       apache1 >= 1.3.33-2
18 Obsoletes:      apache-mod_auth_checkpasswd <= 1.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
22 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
23
24 %description
25 This is an authentication module for Apache that uses an external
26 application compatible with DJB's "checkpasswd". The application may
27 be setuid, which gives you a possibility to verify passwords using
28 regular /etc/shadow.
29
30 %description -l pl
31 To jest modu³ uwierzytelniaj±cy dla Apache który wykorzystuje
32 zewnêtrzn± aplikacjê kompatybiln± z "checkpasswd" DJB. Aplikacja mo¿e
33 byæ suidowana, co daje mo¿liwo¶æ weryfikowania hase³ wykorzystuj±c
34 zwyk³y plik /etc/shadow.
35
36 %prep
37 %setup -q -c -n "mod_%{mod_name}-%{version}"
38 %patch -p1
39
40 %build
41 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
46
47 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
48
49 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
50         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %service -q apache restart
57
58 %postun
59 if [ "$1" = "0" ]; then
60         %service -q apache restart
61 fi
62
63 %triggerpostun -- apache1-mod_%{mod_name} < 1.0-1.1
64 # check that they're not using old apache.conf
65 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
66         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README
72 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
73 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.039624 seconds and 3 git commands to generate.