]> git.pld-linux.org Git - packages/apache1-mod_auth_any.git/blob - apache1-mod_auth_any.spec
- BR s@%{apxs}@apache1-apxs@g
[packages/apache1-mod_auth_any.git] / apache1-mod_auth_any.spec
1 %define mod_name        auth_any
2 %define apxs    /usr/sbin/apxs1
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí shellových příkazů
5 Summary(da.UTF-8):      En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it.UTF-8):      Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb.UTF-8):      En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl.UTF-8):      Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11 Summary(pt.UTF-8):      Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl.UTF-8):      Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv.UTF-8):      Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache1-mod_%{mod_name}
15 Version:        1.5
16 Release:        2
17 Epoch:          1
18 License:        BSD
19 Group:          Networking/Daemons
20 Source0:        http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  a78780db253dd2dc33138f8b644423d2
22 URL:            http://www.itlab.musc.edu/webNIS/mod_auth_any.html
23 BuildRequires:  apache1-apxs
24 BuildRequires:  apache1-devel >= 1.3.33-2
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires(triggerpostun):        %{apxs}
27 Requires:       apache1(EAPI)
28 Obsoletes:      apache-mod_auth_any <= 1:1.5
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34 %description
35 This module allows you to use any command line program (such as
36 webNIS) to authenticate a user.
37
38 %description -l cs.UTF-8
39 Balíček mod_auth_any slouží pro omezení přístupu k dokumentům, které
40 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
41 jakéhokoliv příkazu (jeho návratovým kódem).
42
43 %description -l de.UTF-8
44 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
45 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
46 gegebenen arbiträren Befehls prüft.
47
48 %description -l es.UTF-8
49 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
50 desde un servidor web verificando el código de retorno de un comando
51 arbitrario especificado.
52
53 %description -l fr.UTF-8
54 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
55 servis par un serveur Web en vérifiant le code de retour d'une
56 commande spécifiée arbitraire.
57
58 %description -l it.UTF-8
59 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
60 serviti da un server Web controllando il codice di ritorno di un dato
61 comando arbitrario.
62
63 %description -l ja.UTF-8
64 Mod_auth_any は任意に指定されたコマンドの戻りコードをチェックすること
65 によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
66 ができます。
67
68 %description -l pl.UTF-8
69 Ten moduł pozwala na użycie dowolnego programu działającego z linii
70 poleceń (jak np. webNIS) do uwierzytelniania użytkownika.
71
72 %description -l sv.UTF-8
73 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
74 servade av en webbserver genom att kontrollera returkoden från ett
75 godtyckligt angivet kommando.
76
77 %prep
78 %setup -q -n mod_%{mod_name}
79
80 %build
81 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
86
87 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
88 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
89         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 %service -q apache restart
96
97 %postun
98 if [ "$1" = "0" ]; then
99         %service -q apache restart
100 fi
101
102 %triggerpostun -- apache1-mod_%{mod_name} < 1:1.4-1.1
103 # check that they're not using old apache.conf
104 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
105         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc docs/*
111 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
112 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.071472 seconds and 3 git commands to generate.