]> git.pld-linux.org Git - packages/apache1-mod_auth_any.git/blob - apache1-mod_auth_any.spec
- rel 2; STBR
[packages/apache1-mod_auth_any.git] / apache1-mod_auth_any.spec
1 %define mod_name        auth_any
2 %define apxs    /usr/sbin/apxs1
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
5 Summary(da):    En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de):    Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it):    Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb):    En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl):    Podstawowy modu³ uwierzytelnienia dla Apache, u¿ywaj±cy poleceñ pow³oki
11 Summary(pt):    Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl):    Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv):    Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache1-mod_%{mod_name}
15 Version:        1.4
16 Release:        2
17 Epoch:          1
18 License:        BSD
19 Group:          Networking/Daemons
20 Source0:        http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  73e2aef19a126b77190e59b20486c8d9
22 URL:            http://www.itlab.musc.edu/webNIS/mod_auth_any.html
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache1-devel >= 1.3.33-2
25 Requires(triggerpostun):        %{apxs}
26 Requires:       apache1 >= 1.3.33-2
27 # weird versioning scheme...
28 Obsoletes:      apache-mod_%{mod_name} <= 1:%{version}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34 %description
35 This module allows you to use any command line program (such as
36 webNIS) to authenticate a user.
37
38 %description -l cs
39 Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
40 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
41 jakéhokoliv pøíkazu (jeho návratovým kódem).
42
43 %description -l de
44 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
45 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
46 gegebenen arbiträren Befehls prüft.
47
48 %description -l es
49 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
50 desde un servidor web verificando el código de retorno de un comando
51 arbitrario especificado.
52
53 %description -l fr
54 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
55 servis par un serveur Web en vérifiant le code de retour d'une
56 commande spécifiée arbitraire.
57
58 %description -l it
59 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
60 serviti da un server Web controllando il codice di ritorno di un dato
61 comando arbitrario.
62
63 %description -l ja
64 Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
65 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
66 ¤¬¤Ç¤­¤Þ¤¹¡£
67
68 %description -l pl
69 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
70 poleceñ (jak np. webNIS) do uwierzytelniania u¿ytkownika.
71
72 %description -l sv
73 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
74 servade av en webbserver genom att kontrollera returkoden från ett
75 godtyckligt angivet kommando.
76
77 %prep
78 %setup -q -n mod_%{mod_name}
79
80 %build
81 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
86
87 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
88 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
89         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 if [ -f /var/lock/subsys/apache ]; then
96         /etc/rc.d/init.d/apache restart 1>&2
97 fi
98
99 %preun
100 if [ "$1" = "0" ]; then
101         if [ -f /var/lock/subsys/apache ]; then
102                 /etc/rc.d/init.d/apache restart 1>&2
103         fi
104 fi
105
106 %triggerpostun -- apache1-mod_%{mod_name} < 1:1.4-1.1
107 # check that they're not using old apache.conf
108 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
109         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
110 fi
111
112 %files
113 %defattr(644,root,root,755)
114 %doc docs/*
115 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
116 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.063497 seconds and 3 git commands to generate.