]> git.pld-linux.org Git - packages/apache1-mod_accounting.git/blob - apache1-mod_accounting.spec
- typo
[packages/apache1-mod_accounting.git] / apache1-mod_accounting.spec
1 %define         mod_name        accounting
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: records traffic statistics into a database 
4 Summary(pl):    Modu³ do apache: zapisuje statystyki ruchu do relacyjnej bazy danych
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Group(cs):      Sí»ové/Démoni
11 Group(da):      Netværks/Dæmoner
12 Group(de):      Netzwerkwesen/Server
13 Group(es):      Red/Servidores
14 Group(fr):      Réseau/Serveurs
15 Group(is):      Net/Púkar
16 Group(it):      Rete/Demoni
17 Group(no):      Nettverks/Daemoner
18 Group(pl):      Sieciowe/Serwery
19 Group(pt):      Rede/Servidores
20 Group(ru):      óÅÔØ/äÅÍÏÎÙ
21 Group(sl):      Omre¾ni/Stre¾niki
22 Group(sv):      Nätverk/Demoner
23 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
24 Source0:        http://prdownloads.sourceforge.net/mod-acct/mod_%{mod_name}-%{version}.tar.gz
25 URL:            http://sourceforge.net/projects/mod-acct/
26 BuildRequires:  %{apxs}
27 BuildRequires:  apache-devel
28 BuildRequires:  zlib-devel
29 Prereq:         %{_sbindir}/apxs
30 Requires:       apache
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
34
35 %description
36 mod_accounting is a simple Apache module that can record traffic
37 statistics into a database (bytes in/out per http request).
38
39 %description -l pl
40 mod_accounting jest prostym modu³em Apacza, s³u¿±cym do zapisywania
41 statystyk ruchu do relacyjnej bazy danych (ilo¶æ bajtów
42 wchodz±cych/wychodz±cych na ¿±danie http)
43
44 %prep 
45 %setup -q -n mod_%{mod_name}-%{version}
46
47 %build
48 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_pkglibdir}
53
54 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
61 if [ -f /var/lock/subsys/httpd ]; then
62         /etc/rc.d/init.d/httpd restart 1>&2
63 fi
64
65 %preun
66 if [ "$1" = "0" ]; then
67         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
68         if [ -f /var/lock/subsys/httpd ]; then
69                 /etc/rc.d/init.d/httpd restart 1>&2
70         fi
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.139481 seconds and 3 git commands to generate.