]> git.pld-linux.org Git - packages/apache1-mod_access_referer.git/blob - apache1-mod_access_referer.spec
- massive attack: adding Source-md5
[packages/apache1-mod_access_referer.git] / apache1-mod_access_referer.spec
1 %define         mod_name        access_referer
2 %define         apxs            %{_sbindir}/apxs
3 Summary:        Access control based on "Referer" HTTP header content
4 Summary(pl):    Kontrola dostêpu bazuj±ca na zawarto¶ci standardowego nag³ówka HTTP "REFERER"
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0.2
7 Release:        6
8 License:        Apache Group
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/accessreferer/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  f1726cfe5965eda1bdca90b8db475377
12 Patch0:         http://dl.sourceforge.net/sourceforge/accessreferer/mod_access_referer_1.0.2_third_part_patch.txt
13 URL:            http://sourceforge.net/projects/accessreferer/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache(EAPI)-devel
16 Requires(post,preun):   %{apxs}
17 Requires:       apache(EAPI)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21
22 %description
23 This is an module for the Apache HTTP Server that provides access
24 control based on "Referer" HTTP header content.
25
26 %description -l pl
27 Modu³ ten pozwala na kontrolowanie dostêpu do plików na serwerze w
28 zale¿no¶ci od zawarto¶ci standardowego nag³ówka HTTP - "REFERER"
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32 %patch0 -p0
33
34 %build
35 PATH=$PATH:%{_sbindir}
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_pkglibdir}
41
42 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
49 if [ -f /var/lock/subsys/httpd ]; then
50         /etc/rc.d/init.d/httpd restart 1>&2
51 fi
52
53 %preun
54 if [ "$1" = "0" ]; then
55 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
56         if [ -f /var/lock/subsys/httpd ]; then
57                 /etc/rc.d/init.d/httpd restart 1>&2
58         fi
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README ChangeLog
64 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.801424 seconds and 3 git commands to generate.