]> git.pld-linux.org Git - packages/apache1-mod_access_identd.git/blob - apache1-mod_access_identd.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache1-mod_access_identd.git] / apache1-mod_access_identd.spec
1 %define         mod_name        access_identd
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: access based on ident (RFC1413)
4 Summary(pl):    Modu³ do apache: dostêp na podstawie protoko³u ident (RFC1413)
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.2.0
7 Release:        0.4
8 License:        MeepZor Consulting Public Licence (MCPL)
9 Group:          Networking/Daemons
10 Source0:        http://meepzor.com/packages/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  67a5a1b9d5862eeaf2ba812f6dca98d9
12 Source1:        http://meepzor.com/packages/mod_access_identd/LICENCE.txt
13 URL:            http://meepzor.com/packages/mod_access_identd/
14 BuildRequires:  apache1-devel >= 1.3.33-2
15 Requires:       apache1 >= 1.3.33-2
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
19 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
20
21 %description
22 A security module for the Apache Web server, supplying mandatory
23 access control based upon the client username and host. The
24 credentials are obtained using the identd (RFC1413) mechanism, so this
25 is of limited usefulness if document access is through a proxy or by
26 clients not running an RFC1413 server daemon. As a result, this module
27 is best suited for intranets.
28
29 %description -l pl
30 Modu³ zabezpieczaj±cy dla serwera apache dostarczaj±cy obowi±zkow±
31 kontrolê dostêpu bazuj±c± na nazwie u¿ytkownika i ho¶cie klienta.
32 Listy dostêpu uzyskiwane s± przy pomocy protoko³u ident (RFC1413),
33 zatem u¿yteczno¶æ jest ograniczona je¶li dostêp nastêpuje przez proxy
34 lub klienci nie posiadaj± serwera identd. Modu³ przeznaczony jest do
35 u¿ytku g³ównie w intranetach.
36
37 %prep
38 %setup -q -n mod_%{mod_name}
39
40 %build
41 %{apxs} -c mod_%{mod_name}.c
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
46
47 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
48 cp %{SOURCE1} .
49
50 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
51         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 if [ -f /var/lock/subsys/apache ]; then
58         /etc/rc.d/init.d/apache restart 1>&2
59 fi
60
61 %postun
62 if [ "$1" = "0" ]; then
63         if [ -f /var/lock/subsys/apache ]; then
64                 /etc/rc.d/init.d/apache restart 1>&2
65         fi
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README CHANGELOG mod_access_identd.html LICENCE.txt
71 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
72 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.087366 seconds and 4 git commands to generate.