]> git.pld-linux.org Git - packages/apache1-mod_access_identd.git/blob - apache1-mod_access_identd.spec
- initial
[packages/apache1-mod_access_identd.git] / apache1-mod_access_identd.spec
1 %define         mod_name        access_identd
2 %define         apxs            %{_sbindir}/apxs1
3 Summary:        Apache module: access based on ident (RFC1413)
4 Summary(pl):    Modu³ do apache: dostêp na podstawie protoko³u ident (RFC1413)
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.2.0
7 Release:        0.1
8 License:        MeepZor Consulting Public Licence (MCPL)
9 Group:          Networking/Daemons
10 Source0:        http://meepzor.com/packages/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  67a5a1b9d5862eeaf2ba812f6dca98d9
12 Source1:        http://meepzor.com/packages/mod_access_identd/LICENCE.txt
13 URL:            http://meepzor.com/packages/mod_access_identd/
14 BuildRequires:  apache1-devel
15 Requires(post,preun):   %{apxs}
16 Requires:       apache1
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20 %define         _sysconfdir     /etc/httpd
21
22 %description
23 A security module for the Apache Web server, supplying mandatory
24 access control based upon the client username and host. The
25 credentials are obtained using the identd (RFC1413) mechanism, so this
26 is of limited usefulness if document access is through a proxy or by
27 clients not running an RFC1413 server daemon. As a result, this module
28 is best suited for intranets.
29
30 %description -l pl
31 Modu³ zabezpieczj±cy dla serwera apache dostarczaj±cy obowi±zkow±
32 kontrolê dostêpu bazuj±c± na nazwie u¿ytkownika i ho¶cie klienta.
33 Listy dostêpu uzyskiwane s± przy pomocy protoko³u ident (RFC1413),
34 zatem u¿yteczno¶æ jest ograniczona je¶li dostêp nastêpuje przez proxy
35 lub klienci nie posiadaj± serwera identd. Modu³ przeznaczony jest do
36 u¿ytku g³ównie w intranetach.
37
38 %prep
39 %setup -q -n mod_%{mod_name}
40
41 %build
42 %{apxs} -c mod_%{mod_name}.c
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_pkglibdir}
47
48 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
49 cp %{SOURCE1} .
50
51 %clean
52 #rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63         if [ -f /var/lock/subsys/httpd ]; then
64                 /etc/rc.d/init.d/httpd restart 1>&2
65         fi
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README CHANGELOG mod_access_identd.html LICENCE.txt
71 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.044277 seconds and 3 git commands to generate.