]> git.pld-linux.org Git - packages/apache.git/commitdiff
- rel 2; detect that children died and avoid doing dummy connection when unnecessary auto/th/apache-2.4.4-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 15 Apr 2013 12:29:51 +0000 (14:29 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 15 Apr 2013 12:29:51 +0000 (14:29 +0200)
apache.spec
httpd-dummy-connection-result.patch [new file with mode: 0644]

index ee308526ee51578a0d7ae2d0145d4e4951b1cbb1..d312bc78c4aa4ab3247b77dcecc068828c7e359b 100644 (file)
@@ -35,7 +35,7 @@ Summary(ru.UTF-8):    Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
 Version:       2.4.4
-Release:       1
+Release:       2
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -76,6 +76,7 @@ Patch1:               %{name}-layout.patch
 Patch2:                %{name}-suexec.patch
 Patch3:                %{name}-branding.patch
 Patch4:                %{name}-apr.patch
+Patch5:                httpd-dummy-connection-result.patch
 
 Patch7:                %{name}-syslibs.patch
 
@@ -2586,6 +2587,8 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+
 %patch7 -p1
 
 %patch10 -p1
diff --git a/httpd-dummy-connection-result.patch b/httpd-dummy-connection-result.patch
new file mode 100644 (file)
index 0000000..b2c70cc
--- /dev/null
@@ -0,0 +1,21 @@
+--- httpd-2.4.4.org/server/mpm_unix.c  2012-07-03 21:38:58.000000000 +0200
++++ httpd-2.4.4/server/mpm_unix.c      2013-04-15 14:27:54.197655418 +0200
+@@ -604,7 +604,17 @@
+         len = strlen(data);
+     }
+-    apr_socket_send(sock, data, &len);
++    rv = apr_socket_send(sock, data, &len);
++    if (rv == APR_SUCCESS && lp->protocol && strcasecmp(lp->protocol, "http") == 0) {
++        char *buffer[10]; // dummy buffer to see if child is alive
++
++        len = sizeof(buffer);
++        rv = apr_socket_recv(sock, buffer, &len);
++        if (rv != APR_SUCCESS) {
++            ap_log_error(APLOG_MARK, APLOG_DEBUG, rv, ap_server_conf,
++                         "receiving response to dummy data to listener on %pI", lp->bind_addr);
++        }
++    }
+     apr_socket_close(sock);
+     apr_pool_destroy(p);
This page took 0.200098 seconds and 4 git commands to generate.