]> git.pld-linux.org Git - packages/apache.git/commitdiff
correct place
authorArtur Frysiak <artur@frysiak.net>
Mon, 24 May 1999 12:44:35 +0000 (12:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-suexec.patch -> 1.1
    apache.init -> 1.1
    apache.logrotate -> 1.1

apache-suexec.patch [new file with mode: 0644]
apache.init [new file with mode: 0644]
apache.logrotate [new file with mode: 0644]

diff --git a/apache-suexec.patch b/apache-suexec.patch
new file mode 100644 (file)
index 0000000..c8fd68a
--- /dev/null
@@ -0,0 +1,13 @@
+--- apache_1.3.2/Makefile.tmpl.orig    Fri Sep 25 23:56:02 1998
++++ apache_1.3.2/Makefile.tmpl Fri Sep 25 23:57:37 1998
+@@ -317,10 +317,6 @@
+       -@if [ ".$(suexec)" = .1 ]; then \
+           echo "$(INSTALL_PROGRAM) $(TOP)/$(SRC)/support/suexec $(root)$(sbindir)/suexec"; \
+           $(INSTALL_PROGRAM) $(TOP)/$(SRC)/support/suexec $(root)$(sbindir)/suexec; \
+-          echo "chown root $(root)$(sbindir)/suexec"; \
+-          chown root $(root)$(sbindir)/suexec; \
+-          echo "chmod 4711 $(root)$(sbindir)/suexec"; \
+-          chmod 4711 $(root)$(sbindir)/suexec; \
+           echo "$(INSTALL_DATA) $(TOP)/$(SRC)/support/suexec.8 $(root)$(mandir)/man8/suexec.8"; \
+           $(INSTALL_DATA) $(TOP)/$(SRC)/support/suexec.8 $(root)$(mandir)/man8/suexec.8; \
+       fi
diff --git a/apache.init b/apache.init
new file mode 100644 (file)
index 0000000..10f7986
--- /dev/null
@@ -0,0 +1,48 @@
+#!/bin/bash
+#
+# Startup script for the Apache Web Server
+#
+# chkconfig: 345 85 15
+# description: Apache is a World Wide Web server.  It is used to serve \
+# HTML files and CGI.
+# processname: httpd
+# pidfile: /var/run/httpd.pid
+# config: /etc/httpd/conf/access.conf
+# config: /etc/httpd/conf/httpd.conf
+# config: /etc/httpd/conf/srm.conf
+
+# Source function library.
+. /etc/rc.d/init.d/functions
+
+# Check that networking is up.
+[ "${NETWORKING}" = "no" ] && exit0
+
+# See how we were called.
+case "$1" in
+  start)
+       show Starting httpd
+       daemon +5 httpd 
+       touch /var/lock/subsys/httpd
+       ;;
+  stop)
+       show Shutting down httpd
+       killproc httpd  
+       rm -f /var/lock/subsys/httpd /var/run/httpd.pid
+       ;;
+  status)
+       status httpd
+       ;;
+  restart)
+       $0 stop
+       $0 start
+       ;;
+  *)
+       echo "Usage: $0 {start|stop|restart|status}"
+       exit 1
+       ;;
+esac
+
+exit 0
+
+
+
diff --git a/apache.logrotate b/apache.logrotate
new file mode 100644 (file)
index 0000000..4d046f1
--- /dev/null
@@ -0,0 +1,23 @@
+/var/log/httpd/access_log {
+    postrotate
+       /usr/bin/killall -HUP httpd
+    endscript
+}
+
+/var/log/httpd/agent_log {
+    postrotate
+       /usr/bin/killall -HUP httpd
+    endscript
+}
+
+/var/log/httpd/error_log {
+    postrotate
+       /usr/bin/killall -HUP httpd
+    endscript
+}
+
+/var/log/httpd/referer_log {
+    postrotate
+       /usr/bin/killall -HUP httpd
+    endscript
+}
This page took 0.040949 seconds and 4 git commands to generate.