]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- release 5
[packages/apache.git] / apache.spec
index c9442029a613a84494e77900393c2ee213871fc5..3cf4d76da88084471e18ecf70b65f71d6dd7d33f 100644 (file)
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
 %bcond_without event           # event MPM
+%bcond_with    itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
-#
-%include       /usr/lib/rpm/macros.perl
+
 # this is internal macro, don't change to %%apache_modules_api
 %define                _apache_modules_api 20051115
 
-%if "%{pld_release}" != "ac"
-%define                openssl_ver     0.9.8i
-%else
+%if "%{pld_release}" == "ac"
 %define                openssl_ver     0.9.7d
+%define                apr_ver         1:1.2
+%else
+%define                openssl_ver     0.9.8i
+%define                apr_ver         1:1.4.5
 %endif
+%include       /usr/lib/rpm/macros.perl
 Summary:       The most widely used Web server on the Internet
 Summary(de.UTF-8):     Leading World Wide Web-Server
 Summary(es.UTF-8):     Servidor HTTPD para proveer servicios WWW
@@ -40,12 +43,12 @@ Summary(pt_BR.UTF-8):       Servidor HTTPD para prover serviços WWW
 Summary(ru.UTF-8):     Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
-Version:       2.2.16
-Release:       0.1
+Version:       2.2.21
+Release:       5
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
-# Source0-md5: 7f33f2c8b213ad758c009ae46d2795ed
+# Source0-md5: b24ca6db942a4f8e57c357e5e3058d31
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
@@ -75,6 +78,7 @@ Source26:     %{name}-mod_log_config.conf
 Source27:      %{name}-mod_mime_magic.conf
 Source28:      %{name}-mod_cache.conf
 Source29:      %{name}-example.net.conf
+Source30:      %{name}.tmpfiles
 Patch0:                %{name}-configdir_skip_backups.patch
 Patch1:                %{name}-layout.patch
 Patch2:                %{name}-suexec.patch
@@ -86,7 +90,6 @@ Patch7:               %{name}-syslibs.patch
 Patch8:                httpd-2.0.45-encode.patch
 Patch9:                %{name}-paths.patch
 Patch10:       httpd-2.0.46-dav401dest.patch
-Patch11:       %{name}-bug-40970.patch
 Patch12:       httpd-2.0.46-sslmutex.patch
 Patch14:       httpd-2.0.48-corelimit.patch
 Patch15:       httpd-2.0.48-debuglog.patch
@@ -98,19 +101,19 @@ Patch24:   %{name}-bug-48094.patch
 # http://scripts.mit.edu/trac/browser/trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch?rev=1348
 Patch25:       httpd-2.2.x-mod_ssl-sessioncaching.patch
 Patch26:       apache-mod_vhost_alias_docroot.patch
+# http://mpm-itk.sesse.net/
+Patch28:       apache-mpm-itk.patch
+Patch29:       libtool-tag.patch
 URL:           http://httpd.apache.org/
-BuildRequires: apr-devel >= 1:1.2
-BuildRequires: apr-util-devel >= 1:1.3
-BuildRequires: autoconf
+BuildRequires: apr-devel >= %{apr_ver}
+BuildRequires: apr-util-devel >= 1:1.3.10-2
+BuildRequires: autoconf >= 2.13
 BuildRequires: automake
-BuildRequires: db-devel
 %{?with_distcache:BuildRequires:       distcache-devel}
-BuildRequires: expat-devel
-BuildRequires: gdbm-devel >= 1.8.3
 BuildRequires: libtool >= 2:1.5
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
-%{?with_ssl:BuildRequires:     openssl-devel >= %{openssl_version}}
-%{?with_ssl:BuildRequires:     openssl-tools >= %{openssl_version}}
+%{?with_ssl:BuildRequires:     openssl-devel >= %{openssl_ver}}
+%{?with_ssl:BuildRequires:     openssl-tools >= %{openssl_ver}}
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -194,7 +197,7 @@ Requires(pre):      /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      /sbin/chkconfig
-Requires:      apr >= 1:1.2
+Requires:      apr >= %{apr_ver}
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.1.23
 Provides:      apache(modules-api) = %{_apache_modules_api}
@@ -819,20 +822,33 @@ proxy. Dołączono dwa moduły pozwalające magazynować dane w pamięci
 dysku (używane do cache'owania proxy).
 
 %package mod_case_filter
-Summary:       TODO
+Summary:       Apache output filter that converts all output to upper case
+Summary(pl.UTF-8):     Filtr wyjściowy Apache'a zamieniający wszystkie litery na wielkie
 Group:         Networking/Daemons/HTTP
 Requires:      %{name}-base = %{version}-%{release}
 Provides:      apache(mod_case_filter) = %{version}-%{release}
 
 %description mod_case_filter
+Apache output filter that converts all output to upper case.
+
+%description mod_case_filter -l pl.UTF-8
+Filtr wyjściowy Apache'a zamieniający wszystkie litery w wyjściu na
+wielkie.
 
 %package mod_case_filter_in
-Summary:       TODO
+Summary:       Apache input filter that converts all request body to upper case
+Summary(pl.UTF-8):     Filtr wejściowy Apache'a zamieniający wszystkie litery w żądaniu na wielkie
 Group:         Networking/Daemons/HTTP
 Requires:      %{name}-base = %{version}-%{release}
 Provides:      apache(mod_case_filter_in) = %{version}-%{release}
 
 %description mod_case_filter_in
+Apache input filter that converts all request body (not headers) to
+upper case.
+
+%description mod_case_filter_in -l pl.UTF-8
+Filtr wejściowy Apache'a zamieniający wszystkie litery w ciele żądania
+(ale nie nagłówkach) na wielkie.
 
 %package mod_cern_meta
 Summary:       CERN httpd metafile semantics
@@ -955,6 +971,7 @@ URL:                http://httpd.apache.org/docs/2.2/en/mod/mod_dav.html
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      apache-mod_authn_file
 Requires:      apache-mod_setenvif
+Requires:      apr-util-dbm-db
 Provides:      apache(mod_dav) = %{version}-%{release}
 
 %description mod_dav
@@ -1467,7 +1484,7 @@ HTTP/1.0 i HTTP/1.1.
 
 %package mod_reqtimeout
 Summary:       Apache module to set timeout and minimum data rate for receiving requests
-Summary(pl.UTF-8):     Moduł Apache'a pozwalający na ustawianie timeout oraz minimalnego transferu danych
+Summary(pl.UTF-8):     Moduł Apache'a pozwalający na ustawianie limitu czasu oraz minimalnego transferu danych
 Group:         Networking/Daemons/HTTP
 URL:           http://httpd.apache.org/docs/2.2/mod/mod_reqtimeout.html
 Requires:      %{name}-base = %{version}-%{release}
@@ -1479,7 +1496,7 @@ Apache module to set timeout and minimum data rate for receiving
 requests.
 
 %description mod_reqtimeout -l pl.UTF-8
-Moduł Apache'a pozwalający na ustawianie timeout oraz minimalnego
+Moduł Apache'a pozwalający na ustawianie limitu czasu oraz minimalnego
 transferu danych.
 
 %package mod_rewrite
@@ -1556,7 +1573,7 @@ Epoch:            1
 Group:         Networking/Daemons/HTTP
 URL:           http://httpd.apache.org/docs/2.2/mod/mod_ssl.html
 Requires:      %{name}-base = %{version}-%{release}
-Requires:      openssl >= %{openssl_version}
+Requires:      openssl >= %{openssl_ver}
 %if "%{pld_release}" != "ac"
 Requires:      apr-util-dbm-db
 %endif
@@ -1763,7 +1780,6 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
 %patch12 -p1
 %patch14 -p1
 %patch15 -p1
@@ -1774,9 +1790,11 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
+%patch28 -p1
+%patch29 -p1
 
 # using system apr, apr-util and pcre
-rm -rf srclib/{apr,apr-util,pcre}
+%{__rm} -r srclib/{apr,apr-util,pcre}
 
 # sanity check
 MODULES_API=`awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' include/ap_mmn.h`
@@ -1807,12 +1825,12 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event}; do
+for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
 install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
 ../%configure \
        --enable-layout=PLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" ] && echo "--enable-exception-hook" ) \
+       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" -o "${mpm}" = "itk" ] && echo "--enable-exception-hook" ) \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1891,7 +1909,7 @@ cd ..
 
 done
 
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
                echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
                echo "Build failed."
@@ -1904,14 +1922,15 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT%{_var}/{log/{httpd,archive/httpd},{run,cache}/httpd,lock/mod_dav} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{webapps.d,conf.d,vhosts.d} \
-       $RPM_BUILD_ROOT%{_datadir}/{cgi-bin,vhosts}
+       $RPM_BUILD_ROOT%{_datadir}/{cgi-bin,vhosts} \
+       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 # prefork is default one
 %{__make} -C buildmpm-prefork install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # install other mpm-s
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
 done
 
@@ -1961,6 +1980,8 @@ cp -a %{SOURCE21} $CFG/10_mpm.conf
 cp -a %{SOURCE22} $CFG/20_languages.conf
 cp -a %{SOURCE29} $RPM_BUILD_ROOT%{_sysconfdir}/vhosts.d/example.net.conf
 
+install %{SOURCE30} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+
 echo "LoadModule alias_module modules/mod_alias.so" > $CFG/00_mod_alias.conf
 echo "LoadModule authn_file_module     modules/mod_authn_file.so" > $CFG/00_mod_authn_file.conf
 echo "LoadModule authn_dbm_module      modules/mod_authn_dbm.so" > $CFG/00_mod_authn_dbm.conf
@@ -2012,7 +2033,7 @@ echo "LoadModule substitute_module        modules/mod_substitute.so" > $CFG/00_mod_subs
 echo "LoadModule reqtimeout_module     modules/mod_reqtimeout.so" >> $CFG/00_mod_reqtimeout.conf
 
 # anything in style dir not ending with .css is trash
-rm -rf $RPM_BUILD_ROOT%{_datadir}/manual/style/{lang,latex,xsl}
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/manual/style/{lang,latex,xsl}
 find $RPM_BUILD_ROOT%{_datadir}/manual/style -type f ! -name '*.css' -print0 | xargs -0r rm -f
 
 # find manual files
@@ -2041,11 +2062,11 @@ EOF
 ln -sf suexec $RPM_BUILD_ROOT%{_sbindir}/suexec.fcgi
 
 # no value
-rm $RPM_BUILD_ROOT%{_libexecdir}/build/config.nice
-rm $RPM_BUILD_ROOT%{_libexecdir}/*.exp
-rm $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
-rm $RPM_BUILD_ROOT%{_sysconfdir}/httpd.prefork.conf
-rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/{extra,original}
+%{__rm} $RPM_BUILD_ROOT%{_libexecdir}/build/config.nice
+%{__rm} $RPM_BUILD_ROOT%{_libexecdir}/*.exp
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.prefork.conf
+%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/{extra,original}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -2326,7 +2347,7 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_common.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mpm.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vhosts.d/example.net.conf
+%attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/vhosts.d/example.net.conf
 %attr(640,root,root) %{_sysconfdir}/magic
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/httpd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
@@ -2340,6 +2361,8 @@ fi
 %dir %attr(770,root,http) /var/run/httpd
 %dir %attr(770,root,http) /var/cache/httpd
 
+/usr/lib/tmpfiles.d/%{name}.conf
+
 %{_mandir}/man8/httpd.8*
 
 %attr(2751,root,logs) %dir /var/log/httpd
This page took 0.056246 seconds and 4 git commands to generate.