]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache-apxs.patch
- Vary on User-Agent is insame, Vary on Accept-Encoding instead, also decaces old...
[packages/apache.git] / apache-apxs.patch
index f4bed195e2af8f342982e12a78e49403aab24fd8..7ee05ad5f39e894e694ab40a89bf2e82870cce7d 100644 (file)
@@ -1,40 +1,62 @@
---- httpd-2.0.46/support/apxs.in.orig  Wed May 21 13:39:52 2003
-+++ httpd-2.0.46/support/apxs.in       Thu May 29 07:27:40 2003
-@@ -64,11 +64,11 @@
- my %config_vars = ();
- my $installbuilddir = "@exp_installbuilddir@";
--get_config_vars("$installbuilddir/config_vars.mk",\%config_vars);
-+get_config_vars("/usr/lib/apache/build/config_vars.mk",\%config_vars);
- # read the configuration variables once
--my $prefix         = get_vars("prefix");
-+my $prefix         = "/usr/lib/apache";
- my $CFG_PREFIX     = $prefix;
+--- httpd-2.2.3/support/apxs.in-orig   2006-11-01 00:59:27.000000000 +0100
++++ httpd-2.2.3/support/apxs.in        2006-11-01 00:59:54.000000000 +0100
+@@ -35,6 +35,7 @@
  my $exec_prefix    = get_vars("exec_prefix");
  my $datadir        = get_vars("datadir");
-@@ -228,9 +228,7 @@
- my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
- $httpd = eval qq("$httpd");
- $httpd = eval qq("$httpd");
--my $envvars = get_vars("sbindir") . "/envvars";
--$envvars = eval qq("$envvars");
--$envvars = eval qq("$envvars");
-+my $envvars = "";
+ my $localstatedir  = get_vars("localstatedir");
++my $libdir       = get_vars("libdir");
+ my $CFG_TARGET     = get_vars("progname");
+ my $CFG_SYSCONFDIR = get_vars("sysconfdir");
+ my $CFG_CFLAGS     = join ' ', map { get_vars($_) }
+@@ -44,6 +45,7 @@
+ my $CFG_CC         = get_vars("CC");
+ my $libexecdir     = get_vars("libexecdir");
+ my $CFG_LIBEXECDIR = eval qq("$libexecdir");
++my $CFG_DESTDIR    = '';
+ my $sbindir        = get_vars("sbindir");
+ my $CFG_SBINDIR    = eval qq("$sbindir");
+ my $ltflags        = $ENV{'LTFLAGS'};
+@@ -171,7 +173,7 @@
+           my ($val) = $2;
+           my $oldval = eval "\$CFG_$var";
  
- #allow apxs to be run from the source tree, before installation
- if ($0 =~ m:support/apxs$:) {
-@@ -376,9 +374,9 @@
-     exit(1);
+-          unless ($var and $oldval) {
++          unless ($var and defined $oldval) {
+               print STDERR "apxs:Error: no config variable $var\n";
+               &usage;
+           }
+@@ -199,11 +201,10 @@
+     ($httpd = $0) =~ s:support/apxs$::;
+ }
+-unless (-x "$httpd") {
+-      error("$httpd not found or not executable");
+-      exit 1;
++if (not -x "$httpd") {
++      print STDERR "Note: $httpd not found or not executable.\n";
+ }
+-
++else {
+ unless (grep /mod_so/, `. $envvars && $httpd -l`) {
+     error("Sorry, no shared object support for Apache");
+     error("available under your platform. Make sure");
+@@ -211,7 +212,7 @@
+     error("your server binary `$httpd'.");
+     exit 1;
  }
+-
++}
+ sub get_config_vars{
+     my ($file, $rh_config) = @_;
  
--my $libtool = `$apr_bindir/apr-config --installbuilddir`;
--chomp($libtool);
--$libtool = "$libtool/libtool";
-+#my $libtool = `$apr_bindir/apr-config --installbuilddir`;
-+#chomp($libtool);
-+$libtool = "/usr/bin/libtool";
+@@ -479,8 +480,8 @@
+         $t =~ s|\.[^./\\]+$|\.so|;
+         if ($opt_i) {
+           push(@cmds, "$installbuilddir/instdso.sh SH_LIBTOOL='" .
+-                 "$libtool' $f $CFG_LIBEXECDIR");
+-          push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
++                 "$libtool' $f $CFG_DESTDIR$CFG_LIBEXECDIR");
++          push(@cmds, "chmod 755 $CFG_DESTDIR$CFG_LIBEXECDIR/$t");
+         }
  
- my $apr_includedir = `$apr_bindir/apr-config --includes`;
- chomp($apr_includedir);
+         #   determine module symbolname and filename
This page took 0.364095 seconds and 4 git commands to generate.