]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache-apxs.patch
up to 2.2.24
[packages/apache.git] / apache-apxs.patch
index d2a79f6a47e314bc3582e0ec3aa4615cb343a63f..7ee05ad5f39e894e694ab40a89bf2e82870cce7d 100644 (file)
@@ -1,54 +1,62 @@
---- httpd-2.0.43/support/apxs.in.wiget Thu Sep 19 07:43:16 2002
-+++ httpd-2.0.43/support/apxs.in       Fri Oct  4 11:35:05 2002
-@@ -64,11 +64,11 @@
- my %config_vars = ();
- my $installbuilddir = "@exp_installbuilddir@";
--get_config_vars("$installbuilddir/config_vars.mk",\%config_vars);
-+get_config_vars("/usr/lib/apache/build/config_vars.mk",\%config_vars);
- # read the configuration variables once
--my $prefix         = get_vars("prefix");
-+my $prefix         = "/usr/lib/apache";
- my $CFG_PREFIX     = $prefix;
+--- httpd-2.2.3/support/apxs.in-orig   2006-11-01 00:59:27.000000000 +0100
++++ httpd-2.2.3/support/apxs.in        2006-11-01 00:59:54.000000000 +0100
+@@ -35,6 +35,7 @@
  my $exec_prefix    = get_vars("exec_prefix");
  my $datadir        = get_vars("datadir");
-@@ -228,9 +228,7 @@
- my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
- $httpd = eval qq("$httpd");
- $httpd = eval qq("$httpd");
--my $envvars = get_vars("sbindir") . "/envvars";
--$envvars = eval qq("$envvars");
--$envvars = eval qq("$envvars");
-+my $envvars = "";
- #allow apxs to be run from the source tree, before installation
- if ($0 =~ m:support/apxs$:) {
-@@ -424,7 +422,7 @@
-         $la =~ s|\.c$|.la|;
-         my $o = $s;
-         $o =~ s|\.c$|.o|;
--        push(@cmds, "$installbuilddir/libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
-+        push(@cmds, "/usr/bin/libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
-         unshift(@objs, $lo);
-     }
-@@ -473,7 +471,7 @@
-         $opt .= " -rpath $CFG_LIBEXECDIR -module -avoid-version";
-     }
--    push(@cmds, "$installbuilddir/libtool $ltflags --mode=link $CFG_CC -o $dso_file $opt $lo");
-+    push(@cmds, "/usr/bin/libtool $ltflags --mode=link $CFG_CC -o $dso_file $opt $lo");
-     #   execute the commands
-     &execute_cmds(@cmds);
-@@ -505,7 +503,7 @@
-         $t =~ s|\.la$|\.so|;
+ my $localstatedir  = get_vars("localstatedir");
++my $libdir       = get_vars("libdir");
+ my $CFG_TARGET     = get_vars("progname");
+ my $CFG_SYSCONFDIR = get_vars("sysconfdir");
+ my $CFG_CFLAGS     = join ' ', map { get_vars($_) }
+@@ -44,6 +45,7 @@
+ my $CFG_CC         = get_vars("CC");
+ my $libexecdir     = get_vars("libexecdir");
+ my $CFG_LIBEXECDIR = eval qq("$libexecdir");
++my $CFG_DESTDIR    = '';
+ my $sbindir        = get_vars("sbindir");
+ my $CFG_SBINDIR    = eval qq("$sbindir");
+ my $ltflags        = $ENV{'LTFLAGS'};
+@@ -171,7 +173,7 @@
+           my ($val) = $2;
+           my $oldval = eval "\$CFG_$var";
+-          unless ($var and $oldval) {
++          unless ($var and defined $oldval) {
+               print STDERR "apxs:Error: no config variable $var\n";
+               &usage;
+           }
+@@ -199,11 +201,10 @@
+     ($httpd = $0) =~ s:support/apxs$::;
+ }
+-unless (-x "$httpd") {
+-      error("$httpd not found or not executable");
+-      exit 1;
++if (not -x "$httpd") {
++      print STDERR "Note: $httpd not found or not executable.\n";
+ }
+-
++else {
+ unless (grep /mod_so/, `. $envvars && $httpd -l`) {
+     error("Sorry, no shared object support for Apache");
+     error("available under your platform. Make sure");
+@@ -211,7 +212,7 @@
+     error("your server binary `$httpd'.");
+     exit 1;
+ }
+-
++}
+ sub get_config_vars{
+     my ($file, $rh_config) = @_;
+@@ -479,8 +480,8 @@
+         $t =~ s|\.[^./\\]+$|\.so|;
          if ($opt_i) {
            push(@cmds, "$installbuilddir/instdso.sh SH_LIBTOOL='" .
--                 "$installbuilddir/libtool' $f $CFG_LIBEXECDIR");
-+                 "/usr/bin/libtool' $f $CFG_LIBEXECDIR");
-           push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
+-                 "$libtool' $f $CFG_LIBEXECDIR");
+-          push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
++                 "$libtool' $f $CFG_DESTDIR$CFG_LIBEXECDIR");
++          push(@cmds, "chmod 755 $CFG_DESTDIR$CFG_LIBEXECDIR/$t");
          }
  
+         #   determine module symbolname and filename
This page took 0.074489 seconds and 4 git commands to generate.