]> git.pld-linux.org Git - packages/apache-php-fcgi.git/commitdiff
move apache config as separate file
authorElan Ruusamäe <glen@delfi.ee>
Tue, 26 May 2015 16:05:30 +0000 (19:05 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 26 May 2015 16:05:30 +0000 (19:05 +0300)
apache-php-fcgi.spec
apache.conf [new file with mode: 0644]

index 51077e18d3869a44467e20ab9b278a03deb8403e..03abd20beaee9f34623ec9c7a98915d11db997fc 100644 (file)
@@ -5,6 +5,7 @@ Version:        5.6
 Release:       1
 License:       GPL
 Group:         Applications/WWW
+Source0:       apache.conf
 BuildRequires: apache-devel >= 1.3.39
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      apache-mod_fastcgi
@@ -15,7 +16,6 @@ BuildArch:    noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
-%define                fcgiapp         /usr/bin/php56.fcgi
 
 %description
 This virtual package provides support for the PHP via FastCGI
@@ -24,30 +24,10 @@ protocol.
 %prep
 %setup -qcT
 
-cat <<'EOF' > apache.conf
-# setup via fastcgi to run php5
-<IfModule mod_fastcgi.c>
-       # the server name is bogus actually, to satisfy mod_fastcgi
-       FastCgiExternalServer %{fcgiapp} -socket /var/run/php/fcgi.sock -idle-timeout 120
-       ScriptAlias /php-fcgi %{fcgiapp}
-       <Location "/php-fcgi">
-               SetHandler fastcgi-script
-               Allow from all
-       </Location>
-
-       Action application/x-httpd-php-fcgi /php-fcgi
-</IfModule>
-
-# To register handler for .php in your config context:
-#<IfModule mod_fastcgi.c>
-#      AddType application/x-httpd-php-fcgi .php
-#</IfModule>
-EOF
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
-cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_php-fcgi.conf
+cp -p %{SOURCE0} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_php-fcgi.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
diff --git a/apache.conf b/apache.conf
new file mode 100644 (file)
index 0000000..e25d256
--- /dev/null
@@ -0,0 +1,17 @@
+# setup via fastcgi to run php5
+<IfModule mod_fastcgi.c>
+       # the server name is bogus actually, to satisfy mod_fastcgi
+       FastCgiExternalServer /usr/bin/php56.fcgi -socket /var/run/php/fcgi.sock -idle-timeout 120
+       ScriptAlias /php-fcgi /usr/bin/php56.fcgi
+       <Location "/php-fcgi">
+               SetHandler fastcgi-script
+               Allow from all
+       </Location>
+
+       Action application/x-httpd-php-fcgi /php-fcgi
+</IfModule>
+
+# To register handler for .php in your config context:
+#<IfModule mod_fastcgi.c>
+#      AddType application/x-httpd-php-fcgi .php
+#</IfModule>
This page took 0.129078 seconds and 4 git commands to generate.