]> git.pld-linux.org Git - packages/apache-php-fcgi.git/blob - apache-php-fcgi.spec
03abd20beaee9f34623ec9c7a98915d11db997fc
[packages/apache-php-fcgi.git] / apache-php-fcgi.spec
1 %define         apxs    /usr/sbin/apxs
2 Summary:        Support for the PHP via FastCGI protocol for Apache webserver
3 Name:           apache-php-fcgi
4 Version:        5.6
5 Release:        1
6 License:        GPL
7 Group:          Applications/WWW
8 Source0:        apache.conf
9 BuildRequires:  apache-devel >= 1.3.39
10 BuildRequires:  rpmbuild(macros) >= 1.268
11 Requires:       apache-mod_fastcgi
12 Requires:       php(fcgi)
13 Requires:       php-fcgi-init
14 Provides:       webserver(php) = %{version}
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
19
20 %description
21 This virtual package provides support for the PHP via FastCGI
22 protocol.
23
24 %prep
25 %setup -qcT
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
30 cp -p %{SOURCE0} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_php-fcgi.conf
31
32 %clean
33 rm -rf $RPM_BUILD_ROOT
34
35 %post
36 %service -q httpd restart
37
38 %postun
39 if [ "$1" = "0" ]; then
40         %service -q httpd restart
41 fi
42
43 %files
44 %defattr(644,root,root,755)
45 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_php-fcgi.conf
This page took 0.051663 seconds and 2 git commands to generate.