]> git.pld-linux.org Git - packages/apache-mod_xsendfile.git/blob - apache-mod_xsendfile.spec
- update to 0.9 (new directive: XSendFileAllowAbove)
[packages/apache-mod_xsendfile.git] / apache-mod_xsendfile.spec
1 %define         mod_name        xsendfile
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: processing X-SENDFILE headers
4 Summary(pl.UTF-8):      Moduł Apache'a przetwarzający nagłówki X-SENDFILE
5 Name:           apache-mod_%{mod_name}
6 Version:        0.9
7 Release:        1
8 License:        Apache 2.0
9 Group:          Networking/Daemons
10 Source0:        http://tn123.ath.cx/mod_xsendfile/mod_xsendfile-%{version}.tar.gz
11 # Source0-md5:  a7d22d4027386929c7d69c8f2b050c96
12 URL:            http://tn123.ath.cx/mod_xsendfile/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires:       apache(modules-api) = %apache_modules_api
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
20 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
21 %define         _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
22
23 %description
24 mod_xsendfile is a small Apache2 module that processes X-SENDFILE
25 headers registered by the original output handler. If it encounters
26 the presence of such header it will discard all output and send the
27 file specified by that header instead using Apache internals including
28 all optimizations like caching-headers and sendfile or mmap if
29 configured. It is useful for processing script-output of e.g. PHP,
30 Perl or any CGI.
31
32 %description -l pl.UTF-8
33 mod_xsendfile to mały moduł Apache'a 2 przetwarzający nagłówki
34 X-SENDFILE zarejestrowane przez oryginalną procedurę obsługi wyjścia.
35 Kiedy stwierdzi obecność takiego nagłówka, anuluje całe wyjście i
36 zamiast niego wysyła plik wskazany przez ten nagłówek przy użyciu
37 funkcji wewnętrznych Apache'a wraz ze wszystkimi optymalizacjami,
38 takimi jak buforowanie nagłówków i sendfile/mmap. Moduł ten jest
39 przydatny do przetwarzania wyjścia skryptów, np. PHP, Perla czy
40 dowolnego CGI.
41
42 %prep
43 %setup -q -n mod_xsendfile-%{version}
44
45 %build
46 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
51 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
52 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
53     $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %service -q httpd restart
60
61 %postun
62 if [ "$1" = "0" ]; then
63         %service -q httpd restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Readme.html
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
70 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 1.702433 seconds and 3 git commands to generate.