]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/commitdiff
- initial PLD release auto/th/apache-mod_wsgi-1_0-1
authorPatryk Zawadzki <patrys@room-303.com>
Fri, 5 Oct 2007 13:42:47 +0000 (13:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- provided by Kamil Jakubowski <jakubowski.kamil@3vnet.pl>
- adapterized

Changed files:
    apache-mod_wsgi.conf -> 1.1
    apache-mod_wsgi.spec -> 1.1

apache-mod_wsgi.conf [new file with mode: 0644]
apache-mod_wsgi.spec [new file with mode: 0644]

diff --git a/apache-mod_wsgi.conf b/apache-mod_wsgi.conf
new file mode 100644 (file)
index 0000000..88cad5c
--- /dev/null
@@ -0,0 +1,3 @@
+# $Id$
+LoadModule wsgi_module         modules/mod_wsgi.so
+# vim: filetype=apache ts=4 sw=4 et
diff --git a/apache-mod_wsgi.spec b/apache-mod_wsgi.spec
new file mode 100644 (file)
index 0000000..49dd0d8
--- /dev/null
@@ -0,0 +1,76 @@
+%define                mod_name        wsgi
+%define        apxs            /usr/sbin/apxs
+Summary:       WSGI interface for the Apache Web server
+Summary(pl.UTF-8):     Interfejs WSGI dla serwera WWW Apache
+Name:          apache-mod_%{mod_name}
+Version:       1.0
+Release:       1
+License:       Apache Group License
+Group:         Networking/Daemons
+Source0:       http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
+# Source0-md5: 44e20174c127a50a75f040f881b0a52c
+Source1:       %{name}.conf
+URL:           http://code.google.com/p/modwsgi/
+BuildRequires: apache >= 2.0.52-7
+BuildRequires: apache-apxs >= 2.0.52-7
+BuildRequires: apache-devel >= 2.0.52-7
+BuildRequires: apr-devel >= 1:1.0.0
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: python-devel >= 2.3
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache(modules-api) = %apache_modules_api
+Requires:      apr >= 1:1.0.0
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+
+%description
+The mod_wsgi adapter is an Apache module that provides a WSGI
+compliant interface for hosting Python based web applications within
+Apache. The adapter is written completely in C code against the Apache
+C runtime and for hosting WSGI applications within Apache has a lower
+overhead than using existing WSGI adapters for mod_python or CGI.
+
+%description -l pl.UTF-8
+Adapter mod_wsgi jest modułem udostępniajacym interfejs WSGI dla
+aplikacji WWW napisanych w języku Python i osadzonych w serwerze
+Apache. Adapter jest w całosci napisany w języku C w oparciu o
+bibliotekę runtime Apache i ma mniejsze wymagania niż w przypadku
+używania istniejących adapterów WSGI dla mod_python lub CGI.
+
+%prep
+%setup -q -n mod_%{mod_name}-%{version}
+
+%build
+%{__aclocal}
+%{__autoconf}
+%configure \
+       --with-apxs=%{apxs}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_wsgi.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%service -q httpd restart
+
+%postun
+if [ "$1" = "0" ]; then
+       %service -q httpd restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.1634 seconds and 4 git commands to generate.