]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/blame - apache-mod_wsgi.spec
- apache-apxs -> %{apxs} in BR
[packages/apache-mod_wsgi.git] / apache-mod_wsgi.spec
CommitLineData
c1cb356c
PZ
1%define mod_name wsgi
2%define apxs /usr/sbin/apxs
3Summary: WSGI interface for the Apache Web server
4Summary(pl.UTF-8): Interfejs WSGI dla serwera WWW Apache
5Name: apache-mod_%{mod_name}
6Version: 1.0
7Release: 1
8License: Apache Group License
9Group: Networking/Daemons
10Source0: http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
11# Source0-md5: 44e20174c127a50a75f040f881b0a52c
12Source1: %{name}.conf
13URL: http://code.google.com/p/modwsgi/
14BuildRequires: apache >= 2.0.52-7
dc5b014c 15BuildRequires: %{apxs}
c1cb356c
PZ
16BuildRequires: apache-devel >= 2.0.52-7
17BuildRequires: apr-devel >= 1:1.0.0
18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: python-devel >= 2.3
21BuildRequires: rpmbuild(macros) >= 1.268
22Requires: apache(modules-api) = %apache_modules_api
23Requires: apr >= 1:1.0.0
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
28
29%description
30The mod_wsgi adapter is an Apache module that provides a WSGI
31compliant interface for hosting Python based web applications within
32Apache. The adapter is written completely in C code against the Apache
33C runtime and for hosting WSGI applications within Apache has a lower
34overhead than using existing WSGI adapters for mod_python or CGI.
35
36%description -l pl.UTF-8
37Adapter mod_wsgi jest modułem udostępniajacym interfejs WSGI dla
38aplikacji WWW napisanych w języku Python i osadzonych w serwerze
39Apache. Adapter jest w całosci napisany w języku C w oparciu o
40bibliotekę runtime Apache i ma mniejsze wymagania niż w przypadku
41używania istniejących adapterów WSGI dla mod_python lub CGI.
42
43%prep
44%setup -q -n mod_%{mod_name}-%{version}
45
46%build
47%{__aclocal}
48%{__autoconf}
49%configure \
50 --with-apxs=%{apxs}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
55
56%{__make} install \
57 DESTDIR=$RPM_BUILD_ROOT
58
59install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_wsgi.conf
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post
65%service -q httpd restart
66
67%postun
68if [ "$1" = "0" ]; then
69 %service -q httpd restart
70fi
71
72%files
73%defattr(644,root,root,755)
74%doc README
75%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
76%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.247049 seconds and 4 git commands to generate.