]> git.pld-linux.org Git - packages/apache-mod_watch.git/blob - apache-mod_watch.spec
- tabs in preamble
[packages/apache-mod_watch.git] / apache-mod_watch.spec
1 # TODO
2 # - package -DSTATEDIR=/var/lib/mod_watch ?
3 %define         mod_name        watch
4 %define         apxs            /usr/sbin/apxs
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Apache module: Monitoring Interface for MRTG
7 Summary(pl.UTF-8):      Moduł do apache: Interfejs do monitorowania za pomocą MRTG
8 Name:           apache-mod_%{mod_name}
9 Version:        4.03
10 Release:        5
11 License:        BSD
12 Group:          Networking/Daemons
13 Source0:        http://www.snert.com/Software/download/mod_watch%(echo %{version} | tr -d .).tgz
14 # Source0-md5:  06d57713adb935f16596d22256bca913
15 Source1:        %{name}.conf
16 Patch0:         %{name}-apr-fix.patch
17 URL:            http://www.snert.com/Software/mod_watch/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0.52-2
20 BuildRequires:  rpm-perlprov
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 This module will watch and collect the bytes, requests, and documents
30 in & out per virtual host, file owner, remote IP address, directory or
31 location, and the web server as a whole. This module was designed for
32 use with MRTG, which will make nice graphical representations of the
33 data, but is general enough that it can be applied to other purposes,
34 as the raw data is accessed by a URL. This module supports
35 mod_vhost_alias and mod_gzip.
36
37 %description -l pl.UTF-8
38 Ten moduł kontroluje i zbiera informacje na temat ilości przesłanych
39 bajtów (przychodzących i wychodzących) wg. serwera wirtualnego,
40 właściciela plików, zdalnego adresu IP, katalogu lub lokacji oraz
41 serwera jako całości. Moduł został zaprojektowany do pracy z MRTG,
42 dzięki czemu otrzymamy ładną, graficzną reprezentacje danych. Moduł
43 wspiera mod_vhost_alias oraz mod_gzip.
44
45 %prep
46 %setup -q -n mod_%{mod_name}-4.3
47 %patch0 -p1
48
49 %build
50 %{__make} -f Makefile.dso build \
51         APXS=%{apxs}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir}/httpd.conf}
56
57 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
58 install apache2mrtg.pl mod_watch.pl $RPM_BUILD_ROOT%{_bindir}
59 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/99_mod_watch.conf
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %service -q httpd restart
66
67 %postun
68 if [ "$1" = "0" ]; then
69         %service -q httpd restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc CHANGES* *html *.txt Contrib nfields.pl
75 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
76 %attr(755,root,root) %{_pkglibdir}/*.so
77 %attr(755,root,root) %{_bindir}/*
This page took 0.035673 seconds and 4 git commands to generate.