]> git.pld-linux.org Git - packages/apache-mod_watch.git/blob - apache-mod_watch.spec
- with patch it needs apr1-based apache
[packages/apache-mod_watch.git] / apache-mod_watch.spec
1 %define         mod_name        watch
2 %define         apxs            /usr/sbin/apxs
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Apache module: Monitoring Interface for MRTG
5 Summary(pl):    Modu³ do apache: Interfejs do monitorowania za pomoc± MRTG
6 Name:           apache-mod_%{mod_name}
7 Version:        4.03
8 Release:        4
9 License:        BSD
10 Group:          Networking/Daemons
11 Source0:        http://www.snert.com/Software/download/mod_watch%(echo %{version} | tr -d .).tgz
12 # Source0-md5:  06d57713adb935f16596d22256bca913
13 Source1:        %{name}.conf
14 Patch0:         %{name}-apr-fix.patch
15 URL:            http://www.snert.com/Software/mod_watch/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel >= 2.0.52-2
18 Requires(post,preun):   grep
19 Requires(preun):        fileutils
20 Requires:       apache >= 2.0.52-2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
25
26 %description
27 This module will watch and collect the bytes, requests, and documents
28 in & out per virtual host, file owner, remote-ip address, directory or
29 location, and the web server as a whole. This module was designed for
30 use with MRTG, which will make nice graphical representations of the
31 data, but is general enough that it can be applied to other purposes,
32 as the raw data is accessed by a URL. This module supports
33 mod_vhost_alias and mod_gzip.
34
35 %description -l pl
36 Ten modu³ kontroluje i zbiera informacje na temat ilo¶ci przes³anych
37 bajtów (przychodz±cych i wychodz±cych) wg. serwera wirtualnego, w³a¶ciciela
38 plików, zdalnego adresu ip, katalogu lub lokacji oraz serwera jako ca³o¶ci.
39 Modu³ zosta³ zaprojektowany do pracy z MRTG, dziêki czemu otrzymamy ³adn±,
40 graficzn± reprezentacje danych. Modu³ wspiera mod_vhost_alias oraz mod_gzip.
41
42 %prep
43 %setup -q -n mod_%{mod_name}-4.3
44 %patch0 -p1
45
46 %build
47 %{__make} -f Makefile.dso build \
48         APXS=%{apxs}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir}/httpd.conf}
53
54 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
55 install apache2mrtg.pl mod_watch.pl $RPM_BUILD_ROOT%{_bindir}
56 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/99_mod_watch.conf
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 if [ -f /var/lock/subsys/httpd ]; then
63         /etc/rc.d/init.d/httpd restart 1>&2
64 else
65         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
66 fi
67
68 %preun
69 if [ "$1" = "0" ]; then
70         umask 027
71         if [ -f /var/lock/subsys/httpd ]; then
72                 /etc/rc.d/init.d/httpd restart 1>&2
73         fi
74 fi
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CHANGES* *html *.txt Contrib nfields.pl
79 %attr(755,root,root) %{_bindir}/*
80 %attr(755,root,root) %{_pkglibdir}/*
81 %{_sysconfdir}/httpd.conf/99_mod_watch.conf
This page took 0.039415 seconds and 4 git commands to generate.