]> git.pld-linux.org Git - packages/apache-mod_watch.git/blob - apache-mod_watch.spec
- fix improper usage of %%{_sysconfdir}
[packages/apache-mod_watch.git] / apache-mod_watch.spec
1 %define         mod_name        watch
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Monitoring Interface for MRTG
4 Summary(pl):    Modu³ do apache: Interfejs do monitorowania za pomoc± MRTG
5 Name:           apache-mod_%{mod_name}
6 Version:        3.13
7 Release:        3
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://www.snert.com/Software/mod_watch/mod_watch%(echo %{version} | sed -e "s#\.##g").tgz
11 Source1:        %{name}.conf
12 Patch0:         %{name}-PLD-v6stuff.patch
13 URL:            http://www.snert.com/Software/mod_watch/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache(EAPI)-devel
16 Prereq:         %{_sbindir}/apxs
17 Requires:       apache(EAPI)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21
22 %description
23 This module will watch and collect the bytes, requests, and documents
24 in & out per virtual host, file owner, remote-ip address, directory or
25 location, and the web server as a whole. This module was designed for
26 use with MRTG, which will make nice graphical representations of the
27 data, but is general enough that it can be applied to other purposes,
28 as the raw data is accessed by a URL. This module supports
29 mod_vhost_alias and mod_gzip.
30
31 %description -l pl
32 Ten modu³ kontroluje i zbiera informacje na temat ilo¶ci przes³anych
33 bajtów (przychodz±cych i wychodz±cych) wg. serwera wirtualnego, w³a¶ciciela
34 plików, zdalnego adresu ip, katalogu lub lokacji oraz serwera jako ca³o¶ci.
35 Modu³ zosta³ zaprojektowany do pracy z MRTG, dziêki czemu otrzymamy ³adn±,
36 graficzn± reprezentacje danych. Modu³ wspiera mod_vhost_alias oraz mod_gzip.
37
38 %prep
39 %setup -q -n mod_%{mod_name}-%{version}
40 %patch -p0
41
42 %build
43 %{__make} build-dynamic
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd}
48
49 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
50 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/mod_watch.conf
51
52 mv mod_watch.html mod_watch_pl.html
53 sed -e 's/<!--#/<!--/g' index.shtml > mod_watch.html
54
55 %post
56 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57 if [ -f %{_sysconfdir}/httpd/httpd.conf ] && \
58    ! grep -q "^Include.*mod_watch.conf" %{_sysconfdir}/httpd/httpd.conf; then
59         echo Include %{_sysconfdir}/httpd/mod_watch.conf >> %{_sysconfdir}/httpd/httpd.conf
60 fi
61 if [ -f /var/lock/subsys/httpd ]; then
62         /etc/rc.d/init.d/httpd restart 1>&2
63 else
64         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
65 fi
66
67 %preun
68 if [ "$1" = "0" ]; then
69         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
70         grep -v "^Include.*mod_watch.conf" %{_sysconfdir}/httpd/httpd.conf > \
71                 %{_sysconfdir}/httpd/httpd.conf.tmp
72         mv -f %{_sysconfdir}/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
73         if [ -f /var/lock/subsys/httpd ]; then
74                 /etc/rc.d/init.d/httpd restart 1>&2
75         fi
76 fi
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc CHANGES* *.html
84 %attr(755,root,root) %{_pkglibdir}/*
85 %{_sysconfdir}/httpd/mod_watch.conf
This page took 0.0297 seconds and 4 git commands to generate.